CPU 91 Degree right after turning on the PC

Uctv

Honorable
Nov 24, 2013
29
0
10,530
0
So I have been building my desktop part by part , replacing the old ones with new ones , First I got my 780 GTX , then my i7-4790 CPU with a motherboard Z97X-SOC ,

Everything worked fine for 2 months until i bought a 4K TV and a monster black platinum HDMI cable with a power surge protector just incase.

After plugging my pc into the new surge protector i bought , my PSU stop working , it wouldn't turn on anymore and the fan wasn't moving , my motherboard power button would flash for half a seconds whenever i switch the PSU(
) flip on and off , So after getting a new PSU ZU Series 1000W 80 Plus Bronze and plugging MOST of the plugs ,the pc was turning on while the monitor wasnt getting any signal.


So , after taking out the circle battery looking on the motherboard and putting it back in , my monitor finally got a signal , the screen showed two option, 1 Reset BIOS and boot 2 Reset BIOS and reboot ,
Without much choice i pressed the 2nd one , After the window loaded , I started playing league of legends , I noticed that my FPS would drop dramatically from 7 FPS to 30 FPS , Usually I would always have 60FPS without any question ,even webbrowsing felt really slow , watching a video would stutter sometimes when fully loaded but watching downloaded movies was fine.

Then I realised my BIOS went from F7 to F3 so I did a Live update , then it went back to F7 , the problem still persist , my game was tiny bit faster on FPS wise , my webbrowsing improved too but the problem was still there , It came down to league of legends was barely playable even on Low setting while other games were just FPS laggy all the way.

Went into BIOS settings again and I noticed it say my CPU Temp is at 91 degree (while using the fan that came with the CPU) , even after turning it off , waiting for it to cooldown , it still showed 91 degree as soon i turn it on , even when I tried touching the back of the CPU side , it wasnt that hot.

So I was guessing there was something wrong with my PSU after my motherboard setting got resetted and went to version F3 or maybe I am wrong and its my graphic cards.. I am not sure but I am getting my GTX 980TI delivered to me this monday and I am gonna use my 4K TV as my new monitor so I wanted to get it fixed as soon as possible , Ive tried to be detailed as much as I can even if it wont matter.

BIOS page




I really need you guys help for this =l Thank you for reading
 

lodders

Admirable
Nov 2, 2015
1,888
0
6,460
315
my advice
you need a CPU cooler like a hyper 212 for that CPU
Never buy anything from monster
Spend more time reading about computer building, fault finding and computer components.. you have a lot of enthusiasm, but need a bit more knowledge.
 

lodders

Admirable
Nov 2, 2015
1,888
0
6,460
315
my advice
you need a CPU cooler like a hyper 212 for that CPU
Never buy anything from monster
Spend more time reading about computer building, fault finding and computer components.. you have a lot of enthusiasm, but need a bit more knowledge.
 

Uctv

Honorable
Nov 24, 2013
29
0
10,530
0
Oo , Alright =) Thanks , I was planning on getting a Corsair hydro h100I and It is really fun learning about computer hehe but its just all these new parts came because my friend spilled coke onto my motherboard so I just started learning about 3month ago and gotten new parts slowly up till now , so while not knowing much , I thought that it was my motherboard making my CPU acting up after the reset or my new powersupply supplying too much or whatnot
 

ASK THE COMMUNITY

TRENDING THREADS