CPU always at 99%

Jokoloko

Commendable
Nov 14, 2016
17
0
1,510
0
My CPU, even when not having anything open, is always running at 99% according to Task Manager.
 

Jokoloko

Commendable
Nov 14, 2016
17
0
1,510
0
MERGED QUESTION
Question from Jokoloko : "CPU Always at 99%"

My Intel i5-4590 is always running at or around 99% according to Task Manager. Any help lowering that?
 

Dronzer Dragneel

Respectable
May 13, 2016
402
0
1,960
89
Following steps might help
-go to Task Manager>Processes>look for the program that's using most of the CPU cores..if its not necessary program then try to end that process..even after ending the process if it starts again then uninstall that program (if not necessary).

Note: make sure that program runs under Apps or Background Processes tab, not from Windows Processes. if you end processes from Windows Processes it might damage your OS or Restart/shut your system down.
 

slyverine

Reputable
Mar 4, 2016
789
0
5,360
150
you didn't post ant specs.
when did this started to happen?Is it like ALWAYS at 99%?
are your windows up to date?Maybe it's the windows update running.
what programs use the most according to task manager?
have you checked for viruses and malware?
 

Jokoloko

Commendable
Nov 14, 2016
17
0
1,510
0


sorry
it has been going on for quite a while, maybe a couple months. usually runs around 99% so basically down to 95%
I might need to update windows
Service Host DCOM Server
Yes and I haven't found a virus.
 

slyverine

Reputable
Mar 4, 2016
789
0
5,360
150
Service Host DCOM Server is a service called by many applications when they need it. I guess an application is bugging you and it requests it the whole time. Many people have this problem from what i read. What i will suggest to save you from time to search for a solution would be to backup your data and do a clean install. It will refresh your pc as well!
 

ConfusedOrange

Prominent
Apr 11, 2017
8
0
520
1
Aghhh~ I had this problem so much!
The CPU at 100% is a common problem with most fresh instals of windows 8 or higher, at least I got that with each fresh instal.

My trick to fix these problems was the following

Open Task Manager - Services - Open Services - Find the following services (I will post them bellow) - Propriete - Start up - Disabled

''Background Inteligence Transfere Service
''Superfetch
These 2 are the main ones but I also turn Windows Search and Windows Update to Manual sometimes.

After you do what I told you, just Restart your device - Open Task Manager - Services - Open Services again and check that the Services are now on Disabled.

Hope this helped, it always helped me with the CPU 99% problem.
 

ASK THE COMMUNITY