Question CPU and DRAM Lights on B550 Phantom 4 Gaming motherboard (SOLVED)

Oct 9, 2020
2
0
10
0
My friend has just started his first build today. Everything was going well until he tried to turn it on. . . The fans work fine, but for some reason there is a red light under the GPU and the side saying "CPU and DRAM." It also shows nothing on the monitor and doesn't light up his keyboard and mouse. We tried unplugging the 24 pin and the 8 pin and reseating the ram/placing one stick on each slot. Those did not work, and we have no idea how to fix this. His motherboard is the B550 Phantom 4 Gaming, the memory is Corsair Vengaence 3600 mhz, and the CPU is the ryzen 3600. I will provide other specifications and pictures if needed. Thanks for the assistance!
https://cdn.discordapp.com/attachments/626234713077710880/764273227748605982/20201009_184853.jpg
 
Oct 9, 2020
2
0
10
0
We figured it out! Basically, we tried every ram slot with one stick, taking out the cmos battery and waiting three seconds then putting the battery back in after each stick. Eventually, the first slot worked on one of the ram sticks, and the PC was able to post. We then shut down the pc and put another ram stick for duel channel, and both ram sticks were able to work! For anyone with this problem, make sure you seat the ram and hear that click on both sides with no spaces underneath. If the fans are working and these lights are on, it's not a problem with any of your parts. Just keep troubleshooting!!
 
Jan 23, 2021
5
1
15
0
If the fans are working and these lights are on, it's not a problem with any of your parts. Just keep troubleshooting!!
Hey, hope you are still around to help me out!

I'm trying to get my newbuild with a B550 Phantom 4 motherboard working and have the same fault. Two red LEDs, CPU and DRAM, are lit up.

My monitor says 'No Signal Cable Connected!'. Fans for the chassis and cooler are spinning but not for the GPU. The lights on the Cooler and GPU are on.

What's going on here?
 
Jan 23, 2021
5
1
15
0
Eventually, the first slot worked on one of the ram sticks, and the PC was able to post. We then shut down the pc and put another ram stick for duel channel, and both ram sticks were able to work! For anyone with this problem, make sure you seat the ram and hear that click on both sides with no spaces underneath.
Does the first slot count as the one nearest the CPU or on the edge of the motherboard? Also at one end of the RAM slots is the movable clips I can't quite fix in place. Is that indicative of a problem? The RAM I'm using is Corsair Vengeance LPX (2x 8GB sticks).
 
Jan 23, 2021
5
1
15
0
So Biowatt said that DIMMA1 worked for him so I should put the ram stick in there right? It's been raised as a possibility I have a fault ram stick so I'll try both sticks separately.

I take it that the lights for the CPU and DRAM flash because of that faulty connection rather than the CPU specifically? I hope at least...

Also should the two RAM sticks be installed in separate channels, so the second stick place in A2 or B1?
 
So Biowatt said that DIMMA1 worked for him so I should put the ram stick in there right? It's been raised as a possibility I have a fault ram stick so I'll try both sticks separately.

I take it that the lights for the CPU and DRAM flash because of that faulty connection rather than the CPU specifically? I hope at least...

Also should the two RAM sticks be installed in separate channels, so the second stick place in A2 or B1?
Your motherboard manual recommends DIMM A2 for one stick of RAM, DIMM A2 and B2 for two sticks of RAM.
I am not clear what flashing lights you are referring to?
 

ASK THE COMMUNITY

TRENDING THREADS