Question CPU and GPU usage never max out

May 25, 2022
11
5
15
0
Hello,

I've been monitoring my performance in games (CS:GO, Valorant mostly) using RTSS and I've noticed I never hit max GPU/CPU usage. For example in Valorant I'm usually at 30% cpu usage and 60-70% gpu usage. This is frustrating as I'd like to consistently push 240 frames. I probably have a cpu bottleneck but wouldn't the gpu be hitting high usage in that case? I don't have the best understanding of computer components so any help would be appreciated.

My gpu temps are around 50 degrees C and my cpu temps around 60 degrees C
Specs:
CPU - Ryzen 5 5600G
GPU - Radeon 5500 (not XT)
16 gb 3200 mhz ram
 
It's a prebuilt, the website says erica6
https://support.hp.com/in-en/document/c08052162 <- this pc with another stick of ram
follow this step by step in order (read till end):
  • Disconnect from internet
  • Uninstall gpu driver using DDU (clean and do not restart).
  • Uninstall all the processors (is a must, should be 12 on yours, also when it asks for restart, click on no and keep uninstalling all processors) on device manager like this:


  • Uninstall AMD Chipset Software in control panel (if there is none, skip it.), then update to the latest bios.

  • restart the pc to bios, then load default or optimized settings, disable CSM, enable Above 4G Decoding and Resizable bar option if you want to (these 2 options wont be available unless CSM is disabled, and prolly wont available on your motherboard settings maybe?), then save and exit.

  • boot up to windows and install the latest Chipset driver (should be ver 4.03.xx), then reboot.

  • Install the latest radeon driver or try Amernine Zone Driver , and then connect to internet.

    *do this all offline until reboot after installing chipset driver, also you may reboot to bios after all of this to set the XMP (and previous settings you did). Download needed files (highlighted word) before doing step 1, do the step in orders.

  • Run cmd as admin, then do chkdsk /x /f /r, after that do sfc /scannow.

  • And check windows update if there is any and install them (except optional update). Don't forget to turn on Hardware Accelerated GPU Scheduling (Nvidia GPUs only) in graphics settings and reboot.

  • Make sure the psu connected to the gpu is 1 pcie cable per 1 slot (use main cable, not the branches/split) like this:
 
Reactions: framelover frank
May 25, 2022
11
5
15
0
It's a prebuilt, the website says erica6
https://support.hp.com/in-en/document/c08052162 <- this pc with another stick of ram
follow this step by step in order (read till end):
  • Disconnect from internet
  • Uninstall gpu driver using DDU (clean and do not restart).
  • Uninstall all the processors (is a must, should be 12 on yours, also when it asks for restart, click on no and keep uninstalling all processors) on device manager like this:


  • Uninstall AMD Chipset Software in control panel (if there is none, skip it.), then update to the latest bios.

  • restart the pc to bios, then load default or optimized settings, disable CSM, enable Above 4G Decoding and Resizable bar option if you want to (these 2 options wont be available unless CSM is disabled, and prolly wont available on your motherboard settings maybe?), then save and exit.

  • boot up to windows and install the latest Chipset driver (should be ver 4.03.xx), then reboot.

  • Install the latest radeon driver or try Amernine Zone Driver , and then connect to internet.

    *do this all offline until reboot after installing chipset driver, also you may reboot to bios after all of this to set the XMP (and previous settings you did). Download needed files (highlighted word) before doing step 1, do the step in orders.

  • Run cmd as admin, then do chkdsk /x /f /r, after that do sfc /scannow.

  • And check windows update if there is any and install them (except optional update). Don't forget to turn on Hardware Accelerated GPU Scheduling (Nvidia GPUs only) in graphics settings and reboot.

  • Make sure the psu connected to the gpu is 1 pcie cable per 1 slot (use main cable, not the branches/split) like this:
I’m in my bios but I don’t see the option to disable csm or load optimized settings. I just see secure boot under boot options
 

ASK THE COMMUNITY