[SOLVED] Cpu buzzing pc wont boot

Dec 28, 2019
2
0
10
0
So i am building a budget pc and my psu starts making this buzzing sound as soon as i plug in my 24 pin connecter and turning on the psu , it only makes this noise when the 24 pin is connected the mobo is not in the case and only the cpu and ram is plugged in i tried using different psu and it worked then i tried this psu on a different mobo and it works fine so i know the psu and the motherboard are fine I really dont know what to do now
Also the case fans and cpu fan doesnt spin at all
My specs are
Cpu: core i7 2600
Motherboard: gigabyte ga-h61m-s2pv
Psu: gigabyte 550p(500w)
Gpu: rx480
 

Vic 40

Polypheme
Herald
So i am building a budget pc and my psu starts making this buzzing sound as soon as i plug in my 24 pin connecter and turning on the psu , it only makes this noise when the 24 pin is connected the mobo is not in the case and only the cpu and ram is plugged in i tried using different psu and it worked then i tried this psu on a different mobo and it works fine so i know the psu and the motherboard are fine I really dont know what to do now
If another psu didn't make this sound when using your current motherboard is it this combo that just doesn't work/makes this sound. Might be looking for troubles if continuing with these together.
 

stonecarver

Upstanding
Nov 18, 2019
400
58
290
23
For now I would keep buzzing power supply AWAY from my system. Yes your on a budget but don't let that turn into a quick regret pushing forward if power supply is bad.

Is it New can you return for another unit.
 
Dec 28, 2019
2
0
10
0
For now I would keep buzzing power supply AWAY from my system. Yes your on a budget but don't let that turn into a quick regret pushing forward if power supply is bad.

Is it New can you return for another unit.
Its not new
And i took it to shop to test it it worked fine without buzzing
 

Vic 40

Polypheme
Herald
So i am building a budget pc and my psu starts making this buzzing sound as soon as i plug in my 24 pin connecter and turning on the psu , it only makes this noise when the 24 pin is connected the mobo is not in the case and only the cpu and ram is plugged in i tried using different psu and it worked then i tried this psu on a different mobo and it works fine so i know the psu and the motherboard are fine I really dont know what to do now
If another psu didn't make this sound when using your current motherboard is it this combo that just doesn't work/makes this sound. Might be looking for troubles if continuing with these together.
 

ASK THE COMMUNITY

TRENDING THREADS