[SOLVED] CPU clock speed stuck at 0.80mhz


Mar 17, 2012
So i have had this MSI M9 Ack board for 3, maybe 4 years now, and I have always had some small issues here and there with it, including this - the processor speed getting stuck at 0.80mhz. My brother fixed it last time, but i dont know how he did it, and sadly he is not able to help me anymore. I have done everything i can think of doing - flashed bios, reset cmos, checked if there was updates i missed. I dont know what to do at this point short of breaking this motherboard into tiny pieces and getting something that is less annoying. Can anyone help? If you need more information, i can get it. EDIT: I did forget to say the processor is an i7 6700K
800Mhz (0.80Ghz) I believe is the idle speed your CPU runs when you are not running programs that require more speed. It goes into a lower power state to reduce power used and heat output.

Is the CPU pegged at 800MHz all the time even in games? If you bring up the task manager while running programs like a browser playing a video or a large number of tabs, does the CPU change from 0.80Ghz to something like 1.1Ghz or higher?