Question CPU debug light comes on randomly while gaming ?

Dec 27, 2020
2
0
10
0
Hi, I am using a full AMD Build. Ryzen 5 2600, MSI Tomahawk Max B450, RX5700XT Red Devil Power color, Seasonic Focus Gold Focus 850 Watts -I recently upgraded to a RX5700XT from a RX570 and since then my PC has been crashing to black screen no signal, then CPU debug light would turn on indicating that CPU fails to run a game. This happens randomly on most games that I play.

After I experienced this, i upgraded my PSU from 650 to 850 Gold thinking that's the problem, but the issue still occurs. This only happens when gaming. I tried resetting my OS, changed different Radeon Softwares, DDU'd it, updated all my softwares and MOBO, Cleared CMOS, changing RAM Speed, updated windows and Mobo software. I already replaced my power supply from a 650 Bronze thinking that's the issue, What to do next? its getting really annoying. Tried stress testing my gpu and it seems to be okay too.


Full Spec List:

CPU- Ryzen 5 2600 (Stock cooler)
MOBO- MSI Tomahawk Max B450
GPU- RX5700XT Red Devil Power color
PSU- Seasonic Focus Gold Focus 850 Watts
RAM- CORSAIR VENGEANCE RGB PRO 16GB DUAL DDR4 3200MHZ CL16

Western digital 240GB SSD
Toshiba 2TB HDD
Western Digital 1 TB HDD
 
Dec 23, 2020
15
0
10
0
I have the exact same issue with a similar build, also posted in this forum: https://forums.tomshardware.com/threads/red-cpu-light-on-msi-b450-tomahawk-with-3080-fe-and-2600x-on-high-loads.3673568/

Ryzen 2600X
MSI Tomahawk B450 (no max)
Nvidia 3080 FE
Sharkoon Silentstorm Cool Zero 850W
Corsair Vengeance LPX 16GB 3000 CL15

I also only get black screen crash/Cpu debug light on - only while gaming (warzone, cyberpunk, dirt rally 2) or similar high GPU+CPU loads (3dmark benchmark). Before I replaced my PSU from 600w and my GPU from rtx 2070, I had no issues at all.

I also formatted my drive, reinstalled windows, used DDU and installed drivers.
Mobo bios updated, cleared cmos, disabled/enabled PBO. No changes.
Reseated CPU, reapplied thermal paste, improved case thermals with better fan placement.

I still receive the issue and it's becoming really annoying as well. Temps are perfectly fine, HWinfo64 log during crash also showed nothing out of ordinary, all temps and power delivery looks in order.

The PC boots up perfectly fine, without any POST issues.
The crash/debug light only happens during gaming - and I can not pinpoint what exactly causes this.

I was planning to get a new 850W PSU, in fact, Seasonic Focus GX 850, the same you have, thinking it could resolve the issue. But now I'm not sure if I should replace the PSU anymore since you have the same problem with that.

Benchmarking cpu (aida64) only does not cause this issue. Only sometimes, I can also finish GPU benchmarks (timespy), but sometimes it crashes.
Sometimes for half an hour I can game without issue, but then I get the crash.

Sorry I couldn't help you but really want to hear if you can fix it somehow.
 
Dec 27, 2020
2
0
10
0
I have the exact same issue with a similar build, also posted in this forum: https://forums.tomshardware.com/threads/red-cpu-light-on-msi-b450-tomahawk-with-3080-fe-and-2600x-on-high-loads.3673568/

Ryzen 2600X
MSI Tomahawk B450 (no max)
Nvidia 3080 FE
Sharkoon Silentstorm Cool Zero 850W
Corsair Vengeance LPX 16GB 3000 CL15

I also only get black screen crash/Cpu debug light on - only while gaming (warzone, cyberpunk, dirt rally 2) or similar high GPU+CPU loads (3dmark benchmark). Before I replaced my PSU from 600w and my GPU from rtx 2070, I had no issues at all.

I also formatted my drive, reinstalled windows, used DDU and installed drivers.
Mobo bios updated, cleared cmos, disabled/enabled PBO. No changes.
Reseated CPU, reapplied thermal paste, improved case thermals with better fan placement.

I still receive the issue and it's becoming really annoying as well. Temps are perfectly fine, HWinfo64 log during crash also showed nothing out of ordinary, all temps and power delivery looks in order.

The PC boots up perfectly fine, without any POST issues.
The crash/debug light only happens during gaming - and I can not pinpoint what exactly causes this.

I was planning to get a new 850W PSU, in fact, Seasonic Focus GX 850, the same you have, thinking it could resolve the issue. But now I'm not sure if I should replace the PSU anymore since you have the same problem with that.

Benchmarking cpu (aida64) only does not cause this issue. Only sometimes, I can also finish GPU benchmarks (timespy), but sometimes it crashes.
Sometimes for half an hour I can game without issue, but then I get the crash.

Sorry I couldn't help you but really want to hear if you can fix it somehow.
That's okay. I tried installing all of MSI's application and for now it hasn't happened to me. I'll an update if this fixes the problem.
 

ASK THE COMMUNITY

TRENDING THREADS