Question Cpu debug light coming on

Jan 19, 2020
5
0
10
0
Maybe every 2nd or 3rd start on my newly built pc the red debug light comes on and the pc won’t fully boot. To get past this I have to do a cold restart then it’ll start fine. Could this be some kind of loose wiring?
Running
Msi mpg X570 gaming plus atx
Ryzen 9 3700x
Thanks in advance
 

Ralston18

Titan
Moderator
That is where I would start.

Power down, unplug, and open the case.

Double check all cables, card seatings, RAM, jumpers to ensure that all are fully and firmly in place.

They may feel okay but a closer inspection with a bright flashlight and even a magnifying glass will reveal a tilt, some angle, connectors showing, or some other indication that the component is not fully in place.

Especially motherboard connections.

Look for wires that are out of place or have lots of movement where they can wiggle and cause minor disconnects.

Also make sure that all screws etc. are squarely and fully in place. Could be that heat and expansion is allowing something to move and touch where it should not.
 
Reactions: Barleychee
Jan 19, 2020
5
0
10
0
That is where I will start then. The case is all a bit tight at the back with the amount of wires. Will look into it tonight. Thanks for the help
 
Jan 19, 2020
5
0
10
0
So I’ve been having some issues with windows 10 not restarting. Every 2-3 times it will just get stuck on the restarting screen. Also steam games are stuttering without restarting windows. If I do a cold restart steam runs fine etc.

Today I went to do a restart as steam was stuttering but when I eventually got back on my audio service was not running and troubleshooting it came up with a windows audio and the windows audio end point builder services must be running.

I've gone to reinstall drivers but when I go to click on the file it won’t open unless I open with admin rights. So it then goes to uninstall but gets stuck at this point.

Iv'e tried many fixes to no avail, am I at the point of reinstalling windows?
newly built pc running amd ryzen 9, 2070 super, 16gb ram

Thanks in advance
 

ASK THE COMMUNITY

TRENDING THREADS