Question Cpu ez debug red light on mobo

Jun 3, 2019
6
0
10
0
Hi.

So im havin pc isues with:
Cpu : I7 7700k stock / hyper evo 212 cooler
Mb: msi z270 gaming pro carbon
Ram: corsair lpx black 3000mhz cl15
Gpu: rtx 2070 kfa2
Psu: zalman 700w TX (bad boi psu)

So i had this setup for 2 years exept the gpu card ofc, previous it was gtx 970. Felt like i had to upgrade it a bit. Anyways after these 2 years my pc started crashin after windows 10 clean reinstal. It was just a random hard freeze where the only thing i could do is just force shutdown and power on again.. Till those crashes started accurin too often. Tried to find a solution thinkin mb its win updates, guess it was not. So i figured while checkin bios turnin of the power saving C state mode of the cpu, wich solved my problem. And after 3 months the hard freeze came back. And i thought oh wow here we meet again broski. I did force to shutdown and restart, but now it wont post nothin on screen at all.

When i turn on pc by the sound seems all good. Fans kicks in, hdd chokes as usual, gpu lights on, got that 1st beep too from the mobo and thats it. No display signal, nothing. Like its dead. Hdd doesnt flash when it loads, the power button led doesnt light on either same as 1 of the motherboards fan header doesnt work, though if i put it in another header it works. Seems like some or the motherboard parts doesnt get power. Im tryin to figure the issue if its the mobo or cpu, or mb its my cheap buddy psu startin to strugle?


Tests i did so far r pretty much basic.. First thing i did was try to take take off rams to see if it'll start beeping continuesly and it didnt. Not a single clue of the mobo that rams r missin. Tried unpluggin gpu, hdd, all the fans exept cpu. Still as i said 1 usual beep and no sound of life to atleast enter the bios.

Next thing i did tried takin out cmos battery to reset. Didnt help. Then i tried to reseat the cpu, checked the pins, seems ok. Didnt c any bent pins.. didnt help either. Still cpu red light debug persist.

The last thing i did is, i tried to unplug all the cords and holdin power button for 30 seconds and pluggin all in tryin to start it on again, didnt help.

Can anyone suggest what can b the couse of it? im kinda lost.. ordered new psu just incase to test before buyin other parts..
 

ASK THE COMMUNITY

TRENDING THREADS