Question CPU fan and clock speed always at 100%??

Nov 14, 2019
2
0
10
0
hello! a little over a year ago I was given a gaming computer built by my cousin who works in the IT business, unfortunately he's in another state right now so I can't ask him the questions that I need to, so I'm asking you guys! I'm not too educated on computer parts and how to fix them, but I do know the general idea.

My CPU is intel core i5-3570K and no matter what I run, no matter what I do, the CPU clockspeed and fan speed is always at 100% and it gives me a ton of anxiety. Should I be genuinely concerned? Do I need to look for a replacement?

Here's a screenshot from my CAM application showing my CPU states:
https://prnt.sc/pwq8rq
 
hello! a little over a year ago I was given a gaming computer built by my cousin who works in the IT business, unfortunately he's in another state right now so I can't ask him the questions that I need to, so I'm asking you guys! I'm not too educated on computer parts and how to fix them, but I do know the general idea.

My CPU is intel core i5-3570K and no matter what I run, no matter what I do, the CPU clockspeed and fan speed is always at 100% and it gives me a ton of anxiety. Should I be genuinely concerned? Do I need to look for a replacement?

Here's a screenshot from my CAM application showing my CPU states:
https://prnt.sc/pwq8rq
Looks like it's manually set to it's highest frequency and that turns off any power savings. First thing to try is to set Balanced Power saving plan in windows to minimum CPU to about 10%. If that doesn't work right, you may have to reset CMOS/BIOS to factory defaults.
Temperature is good but fan running full speed can be annoying, there should be an option in BIOS to set it to run at speed according to temperature.
 
Nov 14, 2019
2
0
10
0
Looks like it's manually set to it's highest frequency and that turns off any power savings. First thing to try is to set Balanced Power saving plan in windows to minimum CPU to about 10%. If that doesn't work right, you may have to reset CMOS/BIOS to factory defaults.
Temperature is good but fan running full speed can be annoying, there should be an option in BIOS to set it to run at speed according to temperature.
Alright! I've changed my power saving plan to balanced, where would I look in BIOS to set it to run at speed according to temperature? I have a Gigabyte BIOS if that helps anything.
 

ASK THE COMMUNITY

TRENDING THREADS