Question CPU fan still running and CPU debug light is on after shutdown

May 26, 2020
4
0
10
0
i have just built myself a pc with the following specs:
ryzen 5 3600X
MSI X570 gaming plus
16gb ram
2tb hdd
256gb ssd
RTX 2070

For the past 3 days it was working completely fine and there were no issues with anything at all. However all of a sudden, when i shut it down the 3rd day, the power button on the case stayed on but there was no display on the screen, the gpu and cpu fans were still running. Next to that, the CPU debug light was on. Since then it hasnt shut down properly, the debug light is on and the are running whenever i shut it down.
When i turn the pc on, there is no problem, the debug light turns off.

so what i've gathered is that it didnt fully go into shut down or it might be something else.

I've got the lastest bios adn genuine windows 10.

Could anyone please help me?
 
i have just built myself a pc with the following specs:
ryzen 5 3600X
MSI X570 gaming plus
16gb ram
2tb hdd
256gb ssd
RTX 2070

For the past 3 days it was working completely fine and there were no issues with anything at all. However all of a sudden, when i shut it down the 3rd day, the power button on the case stayed on but there was no display on the screen, the gpu and cpu fans were still running. Next to that, the CPU debug light was on. Since then it hasnt shut down properly, the debug light is on and the are running whenever i shut it down.
When i turn the pc on, there is no problem, the debug light turns off.

so what i've gathered is that it didnt fully go into shut down or it might be something else.

I've got the lastest bios adn genuine windows 10.

Could anyone please help me?
Could be going to sleep instead of full shutdown, It's probably windows problem, check which power plan you are using and how it is set.
Run this line and see what happens, it's once event only.
%windir%\System32\shutdown.exe -s -f -t 00
 
May 26, 2020
4
0
10
0
Could be going to sleep instead of full shutdown, It's probably windows problem, check which power plan you are using and how it is set.
Run this line and see what happens, it's once event only.
%windir%\System32\shutdown.exe -s -f -t 00
Its still done the same thing. however this time the case fans turned off by itself, it didnt have to force shutdown the pc
 
May 26, 2020
4
0
10
0
Nice well balanced pc with good overall choices 👍. But what psu?

Go into bios and disable Fast Boot. You have an SSD as boot drive so Fastboot is moot and just causes more issues than warranted.
Cheers
I have the corsair 650w PSU, alright i'll try that out and see if it done anything
 
May 26, 2020
8
0
10
0
i have just built myself a pc with the following specs:
ryzen 5 3600X
MSI X570 gaming plus
16gb ram
2tb hdd
256gb ssd
RTX 2070

For the past 3 days it was working completely fine and there were no issues with anything at all. However all of a sudden, when i shut it down the 3rd day, the power button on the case stayed on but there was no display on the screen, the gpu and cpu fans were still running. Next to that, the CPU debug light was on. Since then it hasnt shut down properly, the debug light is on and the are running whenever i shut it down.
When i turn the pc on, there is no problem, the debug light turns off.

so what i've gathered is that it didnt fully go into shut down or it might be something else.

I've got the lastest bios adn genuine windows 10.

Could anyone please help me?
 
May 26, 2020
8
0
10
0
I’d check if your power switch/reset switch connectors Are plugged in correctly. My pc wasn’t powering on/off correctly as well and it turned out to be because the power SW pin from my case wasn’t plugged in right.
 
May 26, 2020
4
0
10
0
I’d check if your power switch/reset switch connectors Are plugged in correctly. My pc wasn’t powering on/off correctly as well and it turned out to be because the power SW pin from my case wasn’t plugged in right.
alright i'll have a look at that, i highly doubt it is because of that, but i will double check.
Thanks for the input.
 

ASK THE COMMUNITY

TRENDING THREADS