CPU is never running at full speed, always stuck at 800mhz/0.78ghz

salmonboyak

Prominent
Mar 10, 2018
26
0
530
0
Ever since I first built it, my computer has been running poorly, but I didn't know what was going on until I found out my CPU was running below expectations. In Task Manager it says my CPU runs at 0.78GHZ, and never goes above that during intense tasks, and in CPU-Z it says that my CPU is running at 800mhz.

I am not a computer wizard, so I don't know much about this kind of stuff, though I've tried many ways to fix this problem. Recently I’ve clean installed windows once a few months ago, which didn't help. The temperatures are fine and there’s no dust in it. I already set the Power Plan in Windows to High Performance, did the minimum and maximum thing that I should be doing, still no luck. It never goes to 100% CPU usage, and it never goes above 23% usage when playing a game such as Overwatch or Siege, and when playing such games they run terribly (thanks to the CPU of course). No other parts of my PC are a problem either, they work fine. Just today I tried a BIOS update, which just made my boot time for my PC faster.

I’ve had this PC for about one year now, and I am not any computer expert.

My Specs: ASUS Prime H270M-PLUS, 8GB RAM DDR4-2133, i5 7500 @ 3.40GHz, PNY GTX 1050, and a 450W PSU

Userbenchmark: http://www.userbenchmark.com/UserRun/11278730 (It does say a lot of background is being used, but that's because the CPU just won't go any higher.)

Really like this build, I know it has a lot of potential, but I need to be able to fix my CPU.
 

Doctor Rob

Distinguished
Jul 21, 2008
676
3
19,160
117
DID you add thermal paste to the CPU? it needs it or it will stay at a low speed to help keep it from buring up.

Also make sure you check the power settings in windows that it is not set at like 5% speed as the max or something.
 

salmonboyak

Prominent
Mar 10, 2018
26
0
530
0


Hm, no thermal paste would make sense for the CPU to slow down. I did indeed do the power settings thing also.

Though, if this does clarify anything, my cpu is running at 39C at 800mhz, is that a normal temperature for that speed?
 

ASK THE COMMUNITY

TRENDING THREADS