[SOLVED] CPU issue?

Charseza

Honorable
May 26, 2015
135
2
10,715
5
I recently got an i5 4670, replace my i3 4150.

But upon turning pc on, it turns off in a split second and it stays off.

Ive done my troubleshooting by removing everything except essentials, still wont turn on.

Re seated everything, still wont turn on.

FINALLY, I DECIDED TO TRY TO USE MY OLD CPU AGAIN AND VOILA. IT TURNED ON AND STAYED ON.

Is this a dead processor?
 

SlavfromBulgaria

Prominent
Apr 29, 2020
120
13
615
15
Hello!
I have replaced a 4th gen i3 of my mates with an i5-4570 and it was also a Gigabyte motherboard. Until I went into the BIOS without touching any settings after placing the CPU, the system just refused to boot - stayed on a loop. I would suggest going into your motherboard BIOS try that and if your new CPU is getting recognised it should be fine, but you can't do that. If you try to boot a system without a recognised CPU on Windows 10 I think it gets to the loading screen of Windows but doesn't load into Windows.
If you can, try to see if that CPU works on a different system. If it doesn't - it's a dead CPU.
 

Charseza

Honorable
May 26, 2015
135
2
10,715
5
Alright heres the update.

Turns out, it is indeed the cpu. Upon confronting the guy who sold me this he says this has not been used for a while. So most likely it is indeed a dead cpu. It wouldnt let me turn on my machine but the second I place my i3 4150, boom. No problems whatsoever.

Thanks everyone
 

ASK THE COMMUNITY

TRENDING THREADS