Question CPU LED

Nov 22, 2019
2
0
10
0
So today I did my first PC build. My specs are as follows:

Ryzen 5 3600
Msi MPG x570 Gaming Edge Wifi mobo
Corsair Vengeance RGB 2x8 gb ram
Samsung NVMe M.2 500 gb SSD
MSI Rtx 2070 Super
Corsair cxm 750 psu
NZXT H510 compact mid tower

When I went to turn it on, everything starts up, but it doesn't boot. The CPU LED is on. I had a bit of trouble getting the cpu cooler on and I'm hoping I didn't damage it. Regardless, I'm too tired to start taking stuff apart to check. In the meantime, any other ideas on how to solve this? I checked that my cpu chords were plugged into the psu and the mobo. I removed one, then both sticks of RAM. Still the same thing. Any advice would be much appreciated.

Thanks.
 

Lutfij

Titan
Moderator
You might to inspect the CPU socket and the CPU for any bent pins. The only issue you might face with the cooler is expecting resistance towards the last few turns of the CPU cooler's mounting screws.

Breadbaoard the system with the bare minimum(no fans and what not, just the board, CPU, single stick of ram and the GPU with the boot drive connected only. Which slot is the M.2 populating as well as the rams?
 
Nov 22, 2019
2
0
10
0
You might to inspect the CPU socket and the CPU for any bent pins. The only issue you might face with the cooler is expecting resistance towards the last few turns of the CPU cooler's mounting screws.

Breadbaoard the system with the bare minimum(no fans and what not, just the board, CPU, single stick of ram and the GPU with the boot drive connected only. Which slot is the M.2 populating as well as the rams?
When I was applying the cooler, I wasn't holding the bracket up to the back, so I couldn't get the screws to reach the standoff. I might have applied too much pressure trying to get them in. I suppose I'll check the cpu for damage first, then try a barebones boot. Ram is on A-2 and B-2. I'm not sure what slot the M.2 is on exactly. I used the one that's covered by the heat sync.
 

ASK THE COMMUNITY

TRENDING THREADS