• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

Question CPU nonstop boosting and has high usage

Nov 11, 2019
1
0
10
0
I have upgraded 2 days ago to an ryzen 3700X but after about a day it shot to 100% usage in task manager and nonstop is boosting to 4,2 ghz even if its idling, in HWMonitor it shows that the usage is nonexistant but the clocks are still there and it runs really hot in games and it idles around 60°C
I have tried everything, from upgrading bios to drivers, changing registers and I cant seem to crack down on it.
I can game fine but after few minutes the CPU fan starts spinning like crazy
Iam really desperate about this if someone knows how to fix this please help
PC SPECS:
RYZEN 7 3700X
2x8Gb 3200Mhz CL16 HyperX Fury RGB
MSI X470 Gaming Plus Max
RX 580 Sapphire Nitro+ 8GB

Edit: Found out that my Windows installation was somehow corrupted and it read wrong metrics from the CPU, did a clean install of Windows and its all fine, the CPU was always working as intended
 
Last edited:
Sounds to me, given you have just changed the CPU, it's possible the cooler isn't seated correctly or the thermal paste hasn't been applied exactly right.

It's worth trying to check both. Meaning start from scratch, re-apply thermal paste, and make sure cooler is seated correctly.

Your temps might be a little high when a new application of thermal paste goes on, this is mostly because the paste has to go through a few on/off cycles to harden correctly and produce accurate results. If the application wasn't smooth or done correctly it might cause the high temps, as wood the cooler being off on just one corner if not seated correctly.
 

ASK THE COMMUNITY

TRENDING THREADS