CPU not running at full speed

crisan_tiberiu

Distinguished
Nov 22, 2010
1,185
0
19,660
set your PC power plan to "high performance" in windows when you do heave workloads on your PC. There might be another issue, if you run heavy workload on your CPU for a long time, the CPU might get very hot and then "thermal throtling" kicks in and reduces your CPU speed to reduce the heat.
 

dman4x4

Distinguished
Jan 11, 2012
12
0
18,510


This made big difference, CPU Speed now went up to ~1600MHz, not bad, but still not 2.4GHz.
 

bigmike1

Honorable
Jul 6, 2013
8
0
10,510
for some reason i have speedstep off and thermal throttle off and high performance mode on, but now it wont run 3.8 ghz on my i53570k, it used to a few days ago and nothing changed, pc is a shitty platfrom
 

crisan_tiberiu

Distinguished
Nov 22, 2010
1,185
0
19,660

Disabling Speedstep you also disable "Turbo boost", witch ofc is a "C step". Before accusing the PC beying shitty you should check the part betweeen the PC and the chair :)