Question Cpu Overheating After new watercooler put in

Jan 31, 2021
2
0
10
0
Hi Everyone
After changing from my stock intel Cpu Cooler To a corsair H80i v2.
I noticed that when going into the bios the computer does not detect the cpu cooler at all, the fans are moving on the cooler but the cpu temps go as high as 95 degrees Celsius . anyone know what solutions their are for this
Specs
INTEL i770k
NVidia gtx 1080
24 gb ram
1TB HDD
250 GB SSD
Any advice would be great. Thank you
 
The bios will have no knowledge of any cpu cooler.
All it can detect is that there is a fan connected to the cpu fan header.

Did you remove the protective mylar film on the bottom of the pump before installation?
Is the pump connected to a cpu pump header or at least to a header that is running at 100% ?
Touch the pump, you should feel some vibration.
What is the temperature at idle?
If the cooler is functioning properly, I would expect to see 10-15c. over ambient.
 
Jan 31, 2021
2
0
10
0
The bios will have no knowledge of any cpu cooler.
All it can detect is that there is a fan connected to the cpu fan header.

Did you remove the protective mylar film on the bottom of the pump before installation?
Is the pump connected to a cpu pump header or at least to a header that is running at 100% ?
Touch the pump, you should feel some vibration.
What is the temperature at idle?
If the cooler is functioning properly, I would expect to see 10-15c. over ambient.
Hi geofelt
The idel temp is 95C
After around 15 minuites booting. their is vibrating in the pumps after booting and the pump is conected to the cpu header
 

allidsarebusy

Reputable
Sep 7, 2016
61
22
4,545
1
Ryan,
Check manual of your motherboard. In my case i had a special power supply for Pump and my radiator cooler was connected to the CPU power connector.
 

ASK THE COMMUNITY