[SOLVED] CPU Overheating I7-7700K

Sep 6, 2019
2
0
10
0
I just built a new computer and the CPU seems to be getting hot while I'm playing my games and it is making me lose FPS dramatically. I have reapplied the thermal past and updated the BIOS and windows as well as my graphics card and the only other thing I think I can do is replace the graphics card and/or memory but I wanted to know if there is something I am missing before I buy more memory and install my old graphics card into my new computer. I'm using EVGA Precision X1 to monitor my CPU temp and it seems to run 93C while playing my game and I been told 80C to 85C is normally temp while running games. I don't believe its the airflow because I removed just about everything that could be removed from the tower and all fans are running well.

Windows 10 Pro 64bit
Maximus IX Extreme Motherboard
EVGA Geforce GTX 1080
Corsair Vengeance LPX DDR4 32GB Memory
Samsung SSD 970 EVO Plus M.2 + 1TB HHD Drive
MasterLiquid ML240L
Corsair TX650M Power Supply
 
If it were only running 93C, then you should not be seeing any drop-offs in clock speed due to throttling, as it has not hit the temp where throttling occurs...

Install/run HWMonitor, then run install/run CPU-Z/bench/stress CPU for 15 minutes, and not clock speeds during the run.....you should see 4.2 GHz all-core turbo...sustained, without issue..

(My own 7700K only hits 75C during very heavy/max load when at all-core overclocks of 4.7 GHz, so, something would indeed sure seem to be 'amiss'; note thee core voltage applied during CPU-Z/stress test
 
If it were only running 93C, then you should not be seeing any drop-offs in clock speed due to throttling, as it has not hit the temp where throttling occurs...

Install/run HWMonitor, then run install/run CPU-Z/bench/stress CPU for 15 minutes, and not clock speeds during the run.....you should see 4.2 GHz all-core turbo...sustained, without issue..

(My own 7700K only hits 75C during very heavy/max load when at all-core overclocks of 4.7 GHz, so, something would indeed sure seem to be 'amiss'; note thee core voltage applied during CPU-Z/stress test
 
Sep 6, 2019
2
0
10
0
I installed the HWMonitor and CPU-Z and then used the Bench CPU then stress test and the voltage is ranging from 1.23V-1.26V the Temp is staying below 60C & the clocks are ranging from 4514MHz to 4524MHz

Edit: Can it be the graphics card or Memory causing the problem or is the CPU running 90C+ a common problem to lose FPS?
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS