Question CPU Overheating . Idle at 60 c to 70 degrees 100 C when on load

Sep 11, 2020
3
0
10
0
Hi, I have a desktop (ibuypower ) that i noticed the cpu temperatures running high. The temps are at 60 to 70 degrees Celsius when idle and then they jump to 100 as soon as I run any program that uses the cpu. There is an identical system and that has temps at around 30 C when idle.

CPU : intel 9700k
Mobo: Msi z390-A pro (MS-7B98)
BIOS: vesion 1.10 date 08/22/2018
Ram: 16gb ddr4
Graphics: gtx 1070 Ti
Cooler : AIO cooler from Ibuypower
Storage: Samsung 860 evo + 1tb wd

I have cleaned the PC as well as replaced the thermal compound but have not seen any change.

Please help me figure out what is causing the high temp for the cpu
 
Sep 11, 2020
3
0
10
0
the cooler is iBUYPOWER 240mm Addressable RGB Liquid Cooling System

Unfortunately I cant find the model of the case but i have found an image

The case has 1 fan at the back and a vent at the top enough for 1 fan. The intake is at the front and that is where the radiator is mounted. It also has some intakes at the bottom mostly for the power supply
 
Sep 11, 2020
3
0
10
0
The cooler is properly attached. I reattached it as I replaced the thermal paste.
The RPM does appear on both fans.
I am not sure how to check if the pump is functioning. I can feel a vibration when i hold the tubes.
 

vov4ik_il

Notable
Mar 23, 2020
1,125
146
890
18
I am not sure how to check if the pump is functioning. I can feel a vibration when i hold the tubes.
Since you have two identic systems, I would try to swapping coolers. Otherwise, just try with any air-cooler you might have.

Also, check the vCore voltage. It might be an excessive voltage that gives you those numbers.
 

ASK THE COMMUNITY

TRENDING THREADS