Cpu, PSU, Computer Shut / burning smell

James2103

Prominent
Jul 14, 2017
2
0
510
0
Alright guys, long story short, my Dell PC was experiencing some issues not a while ago like (it would shut off while watching a movie or playing a game) i thought to myself from the start it could be the graphics card, but then i started reading your threads and came to conclusion that its PSU so i have changed it (normal dell PSU) to EVGA 500, at the beginning all good until it happened again then i said ok cool its definitely the graphics card, i ve ignored it though (i know stupid) and today i have decided to clean my pc (main fan, PSU fan Rear Fan plus the graphics card FAN) when i finished pluged it back in it turned on for two seconds then a funny smell occured and now it wont turn on!

Bear in Mind!

- I have changed the PSU and tested it with a different one

- tried clipping it and PSU works!!

- checked motherboard no signs of burned spots


I just want someone if you can please tell me that the graphics card is gone (fan working though) or if it is a motherboard issue and i should burry myslef with my PC!!

Any info will be helpful

Cheers

James


 

James2103

Prominent
Jul 14, 2017
2
0
510
0

Thanks dude, already tried it same thing it just won't start up, fans work for 3 seconds then it wont power up!!
 

hang-the-9

Titan
Moderator


Tried without the video card and it does not turn on? Then could be the motherboard, possibly CPU. You can try resetting the BIOS to defaults with the jumper and see if it works after that. Unplug it from wall power, reset the BIOS, hold in the power button for about 15 seconds, plug it in again and see if it turns on. Burning smell is not good for electronics, so something is likely dead.
 

Similar threads


TRENDING THREADS