Question CPU red led light on after changing RAM

Sep 4, 2019
5
0
10
0
Hello,
So yesterday a friend of mine lend me his 32GB of ram (this one https://www.amazon.co.uk/gp/product/B00A14ZT7E) to try and see if it was compatible with my motherboard.
My current configuration is:
Asus m5a99x evo
AMD FX-8350 cpu
with 3 slots of ram DD3 (2x4GB + 1x8GB)
I removed the currently installed ram and replaced with all the new four slots that my friend gave me. When then I booted the pc, the CPU red light on my motherboard was on and the pc wouldn't boot. I thought it was just the new ram that wasn't compatible, so I switched back my old one. Then something weird happened: the red cpu light was still on and the pc did not boot, even with my old ram!!
So I tried to plug out and back in some cables on my mobo but nothing changed. I then tried with just one ram slot at a time, even in different slots on the mobo, but nothing, still red light.
I then tried the Clear Rtc procedure moving the jumper but nothing, still there. I read that for some people it was the cpu that moved a bit during the procedure, so I'll try to remove it and put it back. Also, someone said that the FX-8350 is a bit fuzzy when you change the ram modules...
Any other suggestion please?
Thanks
 

Ninjawithagun

Distinguished
Aug 28, 2007
710
7
19,165
70
After clearing the CMOS, and returning the jumper back to its nominal position, install only one stick of RAM into channel one of your motherboard. Refer to your motherboard manual for specific slots to install memory based upon single channel configuration. Try starting the computer to see if it will POST. If you hear beeps, count the number of them, or if your motherboard has an onboard LED diagnostics display, write down the number shown. Refer to your motherboard manual to determine which fault is identified and follow the instructions for clearing the issue.
 
Sep 4, 2019
5
0
10
0
After clearing the CMOS, and returning the jumper back to its nominal position, install only one stick of RAM into channel one of your motherboard. Refer to your motherboard manual for specific slots to install memory based upon single channel configuration. Try starting the computer to see if it will POST. If you hear beeps, count the number of them, or if your motherboard has an onboard LED diagnostics display, write down the number shown. Refer to your motherboard manual to determine which fault is identified and follow the instructions for clearing the issue.
I've already tried to clear the CMOS and installing only one stick of ram into the default channel. I'll try to find a speaker cause I don't have currently one installed and see the amount of beeps as you suggested and let you know. Thanks for now.
Do you have any idea why installing different ram could cause hardware failures? As far as I know even if I put incompatible ram into the mobo, nothing that bad could happen. At most it should not boot or cap the ram frequency if it's higher than supported...
 
Sep 4, 2019
5
0
10
0
That is an older motherboard. Worst case, it has been fried somehow and you may be required to get a new one. If that is the case, you may need to consider upgrading your system.
If that's the case, do you recommend any motherboard that supports my current configuration and don't cost a fortune? So one for my current CPU and ddr3.
 

Ninjawithagun

Distinguished
Aug 28, 2007
710
7
19,165
70
The lowest price I could find for a Asus m5a99x evo (AM3+) motherboard is $170 on Newegg. Maybe eBay will have lower pricing. Look for any AM3+ 990X chipset motherboard that might provide similar features.
 
Sep 4, 2019
5
0
10
0
I guess you did have the computer unplugged when you were changing the ram? It is possible the CPU moved a little when you flexed the board.
Yeah I actually had to push a bit to make the ram do the usual "click" when fitting. The power supply had its switch on the OFF state (not the case power button, the actual switch on the supply), so no current was going in through it. But the actual cable was inserted... shouldn't it be the same as having the supply actually unplugged from the socket?
 
Sep 4, 2019
5
0
10
0
So it turns out it was an hardware failure and the mobo is fried. I found the exact same one for about 90$, which is a bit expensive but still less expensive than buying cpu+mobo+ram.
Just one more question please:
When the new mobo arrives, I think I'm going to try again with installing the new ram I was trying before ( this one ). Do you think that this will fry also the new mobo? I really never heard that ram can do that, but still I don't want to destroy also the new one... What do you think?
 

ASK THE COMMUNITY

TRENDING THREADS