[SOLVED] CPU Red Light On Motherboard after swapping CPU's

0ks

Aug 6, 2020
10
0
10
0
I recently upgraded from a Ryzen 5 2600x to a Ryzen 5 3600. Upon powering on the new system the cpu light showed red.

System Specs:
Ryzen 5 2600x/3600
RTX 2070 Windforce
X470 Aorus Ultra Gaming
2x8 GB of some HyperX ram

What I have Already Done
Put 2600x back in
Checked for bent pins on both
8 pin CPU connector was in correctly
24 Pin Motherboard connector was in correctly
System Fan was in correctly

I am honestly running out of ideas for things to try, both cpu's work in another system I have, but not in mine. I know its probably something small or just i cant see but I have exhausted all of my ideas.
 
I recently upgraded from a Ryzen 5 2600x to a Ryzen 5 3600. Upon powering on the new system the cpu light showed red.

System Specs:
Ryzen 5 2600x/3600
RTX 2070 Windforce
X470 Aorus Ultra Gaming
2x8 GB of some HyperX ram

What I have Already Done
Put 2600x back in
Checked for bent pins on both
8 pin CPU connector was in correctly
24 Pin Motherboard connector was in correctly
System Fan was in correctly

I am honestly running out of ideas for things to try, both cpu's work in another system I have, but not in mine. I know its probably something small or just i cant see but I have exhausted all of my ideas.
Did you upgrade the BIOS to F40?
 
Reactions: Archaic59

AngelJin

Proper
Jun 19, 2020
188
51
190
6
Check ur box if it has the ryzen 3rd gen ready if not u need to put old cpu and upgrade ur bios to newer versions go ur mobo will support the 3000 chip.
 

0ks

Aug 6, 2020
10
0
10
0
It was unclear in my first post, but the red light still shows up when I put the 2600x back in, so i cant boot to get bios update.
 

0ks

Aug 6, 2020
10
0
10
0
"I have had the motherboard since before third gen was out, but after checking it out it should be able to run the 3600. "

It won't run it with anything but F40 or later (and I don't see a "later")
I need to be able to boot to get the newer bios though and I still cant boot on the 2600x.
 
Well being the 2600x worked....and now it doesn't....something happened...and being you can't do anything software related (including with the BIOS)...you have to get a CPU to boot....and the only things I can think of at this point....is checking the pins/socket/pads/whatever and possibly cleaning them.
 

Turtle Rig

Prominent
Jun 23, 2020
562
65
490
9
That red light can be RAM or CPU. Check the manual to see. One is near bottom one near top. So you need to find out is it the RAM or CPU. This red light is a very bad thing as it can mean your motherboard situation is botched and although it can be fixable by simply waiting for a while or sticking RAM into different slots or trying different RAM combos, I can almost say surely that your motherboard is bunk sorry to say.
 

0ks

Aug 6, 2020
10
0
10
0
I am glad i could help u mate :)
Ok well after installing bios on the 2nd gen, I swapped to the 3rd gen and now windows is stuck loading. The windows logo just pops up and goes in circles forever. I can get to the windows troubleshooting page through f8, but running the fix start issue just attempts to repair and doesnt fix the problem.
 

ASK THE COMMUNITY