[SOLVED] CPU running at half speed. 1546 MHz rather than overclocked 3800 MHz

Apr 5, 2020
2
0
10
0
Hi hope you guys can help.

My AMD Ryzen 5 1600 on every boot starts running at 1546MHz (1st image) rather than the overclocked 3800MHz (2nd image). The only way I can see to fix it is go into the bios and save and exit immediately and it updates to run at 3800MHz. I have also downloaded Ryzen Master and can select a profile on that which restarts the PC then everything runs smoothly.

I have disabled AMD Cool 'n Quiet. I also have my windows power settings set on 100%. The overclock is stable as I have left the AIDA64 Extreme CPU stress test on for 45 minutes before and had no issues. The only thing I can think of is changing the CMOS battery on my motherboard but I don't really want to reset the bios and I've only had the PC for 2 years.

I know this is a first world problem of sorts as I just need to open Ryzen Master and restart the computer and the CPU speed goes back to 3800MHz. But as you can imagine this is annoying if you just want to pop on the PC for an hour or so. I've attached some images, I hope you can help.

Thanks
 
Apr 5, 2020
2
0
10
0
Corsair 550 Watt CX550M Semi Modular PSU/Power Supply
Hyper X DDR4 8GB RAM
NVIDIA GeForce GTX 1050 GPU
Gigabyte AB350N-Gaming WiFi-CF Motherboard
Brand: American Megatrends Inc
Version: F1

Yeah it probably just needs to happen, will be annoying if it's not the reason though so wanted to check before I did it.

Thanks again
 

ASK THE COMMUNITY

TRENDING THREADS