Question CPU "Stuck" at 0.53 GHz and 14% usage.

Feb 27, 2021
1
0
10
0
Motherboard: ROG Strix X570-I Gaming, CPU: AMD Ryzen 3600x GPU: MSI Armor RX 580 (8 GB) RAM: Corsair Vengeance lpx 16x2 GB 3200mhz PSU: NZXT S650 80+ Gold Storage: SK Hynix Gold 1TB OS: Windows 10, 64-bit, Version 20H2

My CPU is showing as running at 0.53 GHz in task manager and in the BIOS and the utilization in task manager never passes 14%, even when running stress tests. at idle I get 35-36 degrees Celsius and under "load" (it only gets up to 14% usage no matter what I do) I get 37-38 degrees Celsius and in light games that I can load without crashing (ex Polybridge 2) my performance is lacking.

This all started when I switched cases (I switched to the Velka 7) and got a new CPU Cooler (NH-L9a). I have double-checked the CPU power cables to make sure they are all the way in, and I reset all my bios settings to default/auto, CPU and chipset drivers are updated to the most recent versions, I have tried using a different power supply, double-checked the CPU cooler to make sure there was no film on it, the fan does spin and shows up in the bios at 1200 rpm, I have tried to loosen the CPU cooler to see if mounting pressure was the issue, I have set my power plan to performance, and there are no critical errors in the event viewer.

is this just a case of my CPU going bad or is there any way I can fix the problem?
 

Colif

Win 10 Master
Moderator
Do you have the latest bios for motherboard?

Have you used something like Ryzen Master or HWINFO to track usage?
Task manager has never known what speed my 3600XT is doing, it isn't constant like yours but it always thinks its doing 4ghz or more when its way less.

try disabling fast startup, it has been known to fix it - https://www.tenforums.com/tutorials/4189-turn-off-fast-startup-windows-10-a.html
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS