CPU temperature reads -128 degrees celsius


Jul 4, 2009

My CPU is completing its 3rd year of service for me. It shipped as a dual core, but last year I upgraded MoBos and unlocked 2 more cores.

I've had on and off heating issues for about a year (started before I upgraded MoBo), which was probably due to using stock cooling fan. I tried using AS5 compound which would temporarily fix the problem but it recurred. So I upgraded to a monster Zalman cooling fan. That solved the problem too. Then I wake up this morning to a BSoD for the first time on my system. I try restarting and I get black screens after POST except for weird pixels at the top of the screen, and the system is dead in the water. Shut things down, wait a while, open the case, clean stuff out, reseat the Gfx card. Start everything up using last known working configuration and everything seems good for about a half hour and I'm BSoDing again. Swap out gfx cards to see if that's my problem, start up okay, used Speccy to check things out... And get this: my CPU temperature reads 6 degrees celsius. Then 5...4...3..2..1... and then I don't have a CPU temp readout. It also says that my fan speed is merely 26 RPM... Yikes!!! So I quick look up a way to manually set my fan speed higher (and stumble on Speedfan). Download, open it up, and I see that one of my temperature samples (named Temp2) reads -128C. Ahhh!?

Any ideas what's wrong and what's to be done? Thanks!
Well, core temp readings are usually not available (or give very wrong readings) after unlocking extra cores, so that part doesn't surprise me. The strange thing to me is that it ever read the core temps right at all, after the unlock. If you mean the CPU temp and not core temps, I suppose that makes sense, but I have no idea why it would just stop reporting temps correctly.

Re-lock the cores to see what happens.