Question Cpu usage is always in 100% while gpu is only about 50%

Feb 20, 2019
9
0
10
0
I've been trying to figure out what causes this problem but its not getting better

So, wjat i have in my pc is:
Cpu: xeon w3550
Gpu: 660 ti
Ram: 16 gb ddr3

Im pretty sure its not a bottleneck as i already checked it somewhere like a bottleneck calculator ..and also the gpu and cpu were together when i bought it .... now that im trying some heavy games.. it cant handle it and the frame rate seriously drops i dont know how much but its obvious because its unplayable. In task manager i can also see that the gpu is only using like a half of it while the cpu is always at 100%.. Ive read online that 660 ti is a great gpu and should be able to handle those kind of games in 1080 p which is my monitor.. but almost any games except for.moba is too laggy..

It doesnt look like its using all the potential of my gpu but instead it gives all the work in the processor...

Is it my processor or it is something else that causes this problem?
Hope you can help me with this thing .. sorry for my bad english, english isnt my first language..
 

QwerkyPengwen

Dignified
Herald
Well first of all, what game?

Second, when playing a game that has heavy CPU requirements, when your CPU gets overloaded and preferred like that, it limits how fast it can send data to the GPU, and if the CPU is slow enough, then the GPU has to wait and therefore isn't being put under a heavy enough load to be be maxed out.

This is called a CPU bottleneck, because the CPU is bottlenecking the other hardware.

And sorry to say though, neither the CPU or GPU you have is good enough to run the latest games very well.

But if it's older games that should be able to be handled no problem by that hardware, then tell us what games you are trying to play.

If it's newer titles, tell us regardless.
 
Reactions: J4R3D
The GTX660 was a great GPU,... 7 years ago...

You can't expect to run the likes of Witcher3, BF1, BF5, etc. on it and expect good results...

Quake4, MOH, FEAR and most games up through 2012 release should run fine, however...
 
Reactions: J4R3D
Feb 20, 2019
9
0
10
0
Thank you for the repies ... It was gta v and even in low settings its unplayable.. Like it stutters always .. Im planning to upgrade this into w3690 cpu and 1060 gpu but is it enough for this kimd of games..?
 

QwerkyPengwen

Dignified
Herald
I just cross checked your specs with Game-Debate and you shouldn't have any trouble playing that game.

Make sure you have proper installation of DirectX and VC++.

DirectX SDK
https://www.microsoft.com/en-us/download/details.aspx?id=6812

After you install it, download and install the VC++ AiO
https://www.majorgeeks.com/files/details/visual_c_redistributable_runtimes_aio_repack.html

Disable any gamebar/gamemode features in Windows settings.

Go into Windows power plan settings and make sure you are running in High Performance mode.

Double check that you don't have unnecessary processes running in the back ground.
 
Reactions: J4R3D
Feb 20, 2019
9
0
10
0
I just cross checked your specs with Game-Debate and you shouldn't have any trouble playing that game.

Make sure you have proper installation of DirectX and VC++.

DirectX SDK
https://www.microsoft.com/en-us/download/details.aspx?id=6812

After you install it, download and install the VC++ AiO
https://www.majorgeeks.com/files/details/visual_c_redistributable_runtimes_aio_repack.html

Disable any gamebar/gamemode features in Windows settings.

Go into Windows power plan settings and make sure you are running in High Performance mode.

Double check that you don't have unnecessary processes running in the back ground.
Hi.. so i tried to install the direct x and it gave me this error.

"setup failed. Errors were encountered during installation of redistributable packages. Please close all open programs and try running setup again."

so i closed everything but this error still appeared. then i also tried booting into safe mode but failed as well.
 
Feb 20, 2019
9
0
10
0
I tried playing csgo today with the fraps so i can monitor my fps.. it was playable but only at 30 fps and often drop at 20 fps which makes me feel like im going to throw up..
 
Feb 20, 2019
9
0
10
0
I installed direct x first then it gave me that error then i tried it again and that error still showed up ..so i tried to proceed in installing vc++ and also told me some errors that it has some of it already installed in my pc..
 
Feb 20, 2019
9
0
10
0
Okay i got the directx installed succesfully with no errors when i uninstalled all of the vc++ and then i reinstalled it after the directx.. the performance was still the same though.. i should have made a custom pc instead of buying this pc.. this is so frustrating
 
Last edited:
Feb 20, 2019
9
0
10
0
Hi . so i got it fixed when i reinstalled my os for my new ssd cause i just cant migrate it as its havimg a bunch of errors.. its using most of my gpu now.. i usually get 100 fps now ..btw thanks for the response..
 
Last edited:

Similar threads


ASK THE COMMUNITY

TRENDING THREADS