Question Cracking sounds when using Discord w/ headset connected to a USB port, even after full windows reset

svpaz

Prominent
Apr 28, 2019
2
0
510
0
I've been having problems when using any headset connected to a USB hub, which is then connected to my Razer Blade 15" (2019) Advanced laptop. There's audio cracking whenever I'm in a Discord call, even when using Discord in my browser. There's no problem when using my laptop speakers or any bluetooth audio.

I have tried lots of things to try and fix it, like reinstalling / updating drivers, removing any audio enhancements in Discord and in the windows sound device settings, using Discord in a browser, ,and even fully resetting windows. Nothing worked.

I thought it would be a hardware problem, and found that ditching the USB hub and connecting my headset directly to my laptop solved the problem - but why does the headset to USB hub to pc setup work with my other pc? I also do need this USB hub to keep clutter off my desk. So maybe it's the laptop itself that has a problem?

Also, when using the headset with the USB hub, the cracking disappears whenever my laptop is on load, like running a game, installing new drivers, or running "sfc /scannow" and "dism /online /cleanup-image /restorehealth" in command prompt.
The cracking also disappears when I change my power plan to Power Saver, but I don't want to play games while limiting my laptop's capacity.

Is it possible for any software or anything in my laptop to remain unchanged even after windows reset? Maybe the BIOS settings are causing this? I've tried restoring default BIOS settings to no avail.
I also remember that I updated my BIOS a few days before this problem started. I just can't find a download link to an older Razer Blade BIOS version

System specs (Razer Blade 15 (2019) Advanced):
  • GPU: Nvidia GeForce RTX 2060, Intel(R) UHD Graphics 630
  • CPU: Intel(R)
  • Core(TM) i7-8750H
  • RAM: 18GB
 

ASK THE COMMUNITY

TRENDING THREADS