Crashing with no BSOD in Game after GPU upgrade

A really nice hat

Reputable
Jan 2, 2015
61
0
4,630
0
I recently bought a new Graphics card (R9 390x) to replace my GTX 960. In addition I also bought a 750 Watt EVGA PSU. Whenever I'm in game for a period of time it eventually freezes and crashes and automatically restarts my computer. I get no blue screen of death and no error message when my computer reboots. Temperatures of my GPU never exceed 80 C and CPU never exceeds 55 C.

System Specs:
Windows 10 64-bit
GPU - XFX R9 390x
CPU - Intel i5 3570k
PSU - 750w EVGA Bronze Rated
8 Gigs of DDR3 Ram
Motherboard - Gigabyte B75M-D3H
 

nitrium

Distinguished
Jul 27, 2009
1,423
2
19,665
194
Potentially your PSU isn't providing enough juice for the VERY thirsty AMD 390X. You might need to upgrade your PSU with something from this list:
http://www.tomshardware.com/forum/id-2547993/psu-tier-list.html

Other easy things to try is to make sure all power cables are properly connected to the GPU, and the GPU is seated properly - these are heavy and long cards, so in tower cases they can droop (and potentially loose contact with the PCIe slot) if the rear bracket isn't secured properly and causes crashes like that which you describe. I've attached a cable tie to the front end of my Sapphire Nitro 390 to the chassis to better secure it.
 

A really nice hat

Reputable
Jan 2, 2015
61
0
4,630
0
Im trying to help my friend with the problem and i have the same card and only a 650w psu and have no problems. As for the connections they all seem good. Also there is no sag.
 

nitrium

Distinguished
Jul 27, 2009
1,423
2
19,665
194

Not all PSUs are created equal! I'm running mine off just a 560W supply - but it's a Seasonic with a single 12V rail. Hard to tell what the issue, but I suspect it probably is a iffy PSU. Try swapping the GPUs around, and see if you have any problems with it in your system. That way you'll be certain the GPU itself isn't the problem.
 

Leonea Jonhy

Reputable
Aug 14, 2015
79
0
4,660
6
80% that is amd shetty drivers fault sugest or roll back drivers to previous drivers or update it to newest one its because youre card has elpida memory on it and drivers delivers unstable voltage to memory i height amd because there sheety drivers
 

nitrium

Distinguished
Jul 27, 2009
1,423
2
19,665
194

Your terrible grammar and spelling aside, I've had AMD GPUs for two gens now (HD7950 and R9 390) and the drivers have not been a problem. Indeed, I hear a lot more issues involving NVIDIA drivers than AMD lately.
Oh and his GPU will have Hynix (NOT Elphida) GDDR5 memory on it, so not even that is true. Your entire post is just spreading TOTALLY worthless disinformation. http://www.overclockersclub.com/reviews/xfx_r9_390x/
http://www.overclockersclub.com/reviews/xfx_r9_390x/#&gid=1&pid=90511
If you have no actual useful/truthful information to share, it's honestly better to not bother posting here.
 

Vomrath

Commendable
Aug 5, 2016
48
0
1,540
1
The problem just turned out to be outdated/Inadequate ram for the card. Hours of troubleshooting just to find out the problem was crappy components.
 

Similar threads


ASK THE COMMUNITY