Question Create and Connect to external server via internet

May 24, 2019
13
0
20
1
Hi, I need a little help to create an FTP server at home that I can access from outside of my network using FileZilla (I do not have a networking background and I understand it would be the easiest to configure).

The settings I made in FileZilla Server are the following:
Listen on these ports: 2121
Use custom port range: 19000-20000
If it is to stay on Default I get the error You appear to be behind a NAT router. Please configure the passive mode settings and forward a range of ports in your router.
External Server IP Address for passive mode transfers: Use the following IP: 172.22.22.11 (not my real IP but I understand that it is here where I must put my real IP)
and I do not know how to connect (from FileZilla Client) if I choose the third option Retrieve external ip address from: http://ip.filezilla-project.org/ip.php

For Windows Defender Firewall I added filezilla to the Allowed Apps and Features list with both checked boxes(Private and Public).
I created 3 new rules for Inbound Rules
  1. Allow Program FileZilla Server.exe
  2. Allow Main Port 2121 (TCP)
  3. Allow Range Ports 19000-20000 (TCP)
And for the router is a zte-F668 with this settings made ( I don't know if this settings are correct)
ip address: 192.168.1.3 is my home computer connected with Wi-Fi (windows 10 Pro)

and for Filezilla Client i use
Host: 172.22.22.11 (not my real IP but I understand that it is here where I must put my real IP)
user: testME (user is created and sharefolder added in Filezilla Server)
Password: testeme2
port: 2121
And I still can not connect:
Errors I get are :
econnrefused - connection refused by server
or
Connection timed out after 20s of inactivity
Could not connect to server
 

QwerkyPengwen

Dignified
Herald
To help clarify a couple of things.

Make sure port forwarding settings match those for filezilla.

Next, make sure firewall settings in Windows are correct.

Make sure your PC is connected using a static IP address so that it never gets changed by the router.

Make sure that no other programs or Windows services are using the same port that filezilla uses.

There's also a thing you have to do involving setting up a user account the proper way.

Refer to this guide for setting things up
 
May 24, 2019
13
0
20
1
Thank you for your interest,
yes, I checked to see if the settings are correct.
FileZilla Server are the following: Main ports: 2121, port range: 19000-20000 and for the router you can see from the 2 screenshot.
As for Windows Firewall like I said i added to the Allowed Apps and Features list Filezilla Server.exe, rules to Inbound Rules.
Yes, i have Static IP address.
For ports used by other programs i used in command prompt netstat -an and didn't see any ports used from my range of 19000-20000 listed.
For setting up a user account the proper way i used that exact guide to set it up.
The only thing i don't know if is correct is in pic 1 at ingress and egress if I need to select a option there?
 
Last edited:
May 24, 2019
13
0
20
1
Now if I use in Filezilla Server Retrieve external ip address from: http://ip.filezilla-project.org/ip.php
and in FileZilla Client host I input my [ipv6 IP address]
I get error : Connection attempt failed with "ENETUNREACH - Network unreachable"
A little online search show that this error is generated IF I have Anti-Virus Kasperky.
I don't have Kasperky on any of my machines.
 

QwerkyPengwen

Dignified
Herald
May also not your provider but just the router you're using.

I personally had this issue with ports before using my ISP provided router, but they weren't blocking anything themselves and it turned out to just be th their router, so I returned it and stopped paying monthly for it and went and bought my current router that has performed excellently for only $40.
 
May 24, 2019
13
0
20
1
I talked with my ISP and they told me that they don't have any port blocked and if i need to do any port forwarding I will need to change my router.o_O
 
I talked with my ISP and they told me that they don't have any port blocked and if i need to do any port forwarding I will need to change my router.o_O
Those router settings are wrong.
  1. Delete security ip filter rule. It is wrong and not necessary.
  2. In port forwarding rule wan host ip address should be your external ip address. Currently you have local host ip address there.
  3. Make another port forwarding rule for port 2121. You have not opened it yet and it's not possible to connect to it from outside.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts