Question Creative Sound BlasterX Kratos S5 Not Detected

PureChaosX

Commendable
Jul 12, 2017
5
0
1,510
0
Recently purchased a set of these speakers off eBay, knowing they were faulty but not sure to what extent. Seller said he couldn't connect to his PC but it did have the USB cable, so figured it might just be a driver issue.... it was not.

I plugged the speakers in to my PC and Win10 installed the drivers immediately. I thought "well, that was easy" ...however I noticed that although the speakers were listed in Devices in the Control Panel, it was under Other Devices, not Audio and it's listed as "SBX Kratos S5 Upgrade" .... why does it say Upgrade at the end?

On top of that, I can't for the life of me find the speakers in the Device Manager, it just doesn't exist, not under USB Controllers, Audio Inputs, Sound etc... it's just nowhere to be seen.

I tried installing the Creative Sound Blaster Connect software, but said it couldn't find any compatible Creative hardware. Same thing happened when I tried to update the firmware.

I've also tried different USB 2.0, ports, tired all USB 3.0 ports, tried a different USB cable... nothing. On top of that, the LEDs on the speakers do not light up when powered on (not sure if they're supposed though).

I have not yet tried the speakers through the normal 3.5mm speaker jack, but even if that did work, I'd be unable to use the features of the speakers, which I kinda want to do.

Does anyone know what might be the cause behind this? Or has anyone owned these speakers and had similar problems? Any help or info would be great. Cheers.

UPDATE: Tried 3.5mm connection instead and still didn't work. Power LED lights up when plugged in but I think it's supposed to turn on once you've turned the unit on. Also, the RGB LEDs on the speakers randomly light up when plugged in, even if the unit is turned off.

I'm suspecting some sort of power short somewhere, since it's powered on of sorts, when powered off.
 

kymoddj

Reputable
Apr 7, 2016
1
0
4,510
0
Did you find any solutions yet?
I have the same problem here.
Here's what happened:
So today i just purchased the above speakers,Plugged them to my pc with the usb cable and they were working fine. I downloaded the driver from creative's official website and when i tried to install it it said "we found a new firmware for your device, Upgrade it now." I pressed "Upgrade" but then i got an error message the device failed to upgrade please unplug and plug them again. I did it but no audio. RGB stopped working, tried audio jack without any success, tried the red and white cable to audio jack without any success again.

So maybe i bricked the speakers from the firmware upgrade?
 

PureChaosX

Commendable
Jul 12, 2017
5
0
1,510
0
Funny you should mention that, as i was able to fix them a week ago after getting in touch with Creative Support.

The problems you seem to be having are more or less identical to mine. They helped me fix my speakers by providing a Firmware Updater only Creative Support can provide. It's different to the normal updater on the website, as it seems to force a repair reinstall of the firmware.

I've uploaded the software to my Google Drive and I'll post a link to it.

Creative Firmware Updater

Hopefully this will get your speakers working again. Good luck!
 

ASK THE COMMUNITY

TRENDING THREADS