Crossfire and Subsequent Monitor Destruction (Two-part Question)

LuftWaffle

Honorable
Jun 2, 2013
19
0
10,510
0
So I've decided to Crossfire a 7950 with a new 7970.

Everyday, at random times of the day, I'd get a full screen graphical glitch that looks like this (changes from day to day.



A restart fixes this issue. This issue started after Crossfire so it probably is part of the problem.

However, after the last artifact, my monitor began flickering in the same pattern as the artifact. I can get to Windows just fine after a restart. Except my monitor now just jitters no matter what it's displaying.

So my questions are as followed:

1. Is Crossfire just this buggy to cause daily artifact issues, or is it something with my new 7970?

2. Did my monitor just get "fried" by the artifact? The jitter will not stop, and I've tried everything.
 

Mouldread

Honorable
Apr 17, 2013
978
0
11,360
159
Hey, this about the monitor was just an idea. You never know :)

For some reason I think it could be caused by some cable. Have you inspected all your cables - the 6-8 pin ones powering the cards, the x-fire bridge, the cable connecting the monitor to the GPU?

Just giving you ideas that come to mind.
 

LuftWaffle

Honorable
Jun 2, 2013
19
0
10,510
0


As of now, the screen has stopped trembling (after two hours of rest). However, I'll keep an eye out for any future potential artifacts.
I have switched primary cards and the Crossfire bridge. I have also stopped overclocking.

 

Similar threads


TRENDING THREADS