[SOLVED] Crossover LAN not working

domes03

Honorable
Aug 21, 2012
19
0
10,510
0
Hey everyone, I've been having a real frustrating head-scratcher with LAN via Crossover for my sister's office/reception area.

The building has Ethernet ports in the walls, numbered and with a central switch in a closet with the rest of the internet stuff (router from ISP, cable box, etc.) and I have been trying what I thought would be a no-brainer easy task of setting up LAN between her PC in the downstairs reception area, and an office upstairs.

All went well to begin with,
  1. plugged a Crossover from each PC to its respective port in the wall (8 and 15.)
  2. Then a Crossover in the closet from port 8 to port 15, all good so far.
  3. Set the network adapter settings for the Ethernet ports on each PC to only connect to a static IP, by going to Adapter Settings, going to TCP/IPv4, and entering a given address for one computer (ex: 123.123.123.1) and then setting the gateway to the other PC's (123.123.123.2) leaving the Subnet as defaulted and the DNS as 8.8.8.8.
  4. Changed Advanced Sharing Settings to each PC to Allow Network Discovery, File and Printer Sharing, and disabled Password Protected Sharing.
  5. Then right clicking on the folder to share, Giving Access to Specific People, adding Everyone, changing permissions to Read/Write.
  6. And finally, right clicking the folder, Properties, Sharing, Advanced Sharing, and enabling Sharing of the folder as well as giving Permissions to everyone.
This worked great!...For the computer upstairs!....To begin with.
Upstairs computer immediately picked up the downstairs one on the Network tab of File Browser, could access the files, and move new ones in, as well as copy existing ones out.
Downstairs was a different story, it was not detecting anything on the Network, and after checking the settings one last time, from that point forward neither can see one another! What's more is I am getting a "Network Cable Unplugged" indicator on the Adapter list, despite the crossovers all being connected still.

I have tried:
  • Resetting network settings.
  • Redoing all TCP/IPv4 settings on each computer, setting IPs and DNS again.
  • Redoing Sharing Settings on both the folders, as well as as the Advanced Sharing Center.
  • Uninstalling the Adapter Drivers for the Ethernet Ports, then updating/installing new ones.
Nothing has worked! I'm about my wit's end here and could really use some help! Any ideas?
 

kanewolf

Titan
Moderator
Unless those are old PCs, I would recommend straight through cables. Gigabit network ports will automatically crossover if required.
In a situation like you have, where you don't have a router or other public network access on this LAN, I would not put a gateway on either PC. Use standard private IP addresses 192.168.x.y and you also don't have a DNS on this private LAN so setting 8.8.8.8 isn't really valid either.
 

kanewolf

Titan
Moderator
Unless those are old PCs, I would recommend straight through cables. Gigabit network ports will automatically crossover if required.
In a situation like you have, where you don't have a router or other public network access on this LAN, I would not put a gateway on either PC. Use standard private IP addresses 192.168.x.y and you also don't have a DNS on this private LAN so setting 8.8.8.8 isn't really valid either.
 

hang-the-9

Titan
Moderator
Mar 25, 2010
60,215
1,036
152,890
16,799
Why are you using crossover cables? Those are only needed when you connect two computers directly to each-other, not when using any sort of switches or hubs.
Also set the IP settings to defaults, let the router assign them using DHCP. Sounds like you are trying a bit too hard to configure things that are not needed to be configured.
 

ASK THE COMMUNITY