Crucial M4 256gb Crash


Aug 18, 2012
Hi tom's hardware

I bought a Crucial M4 256GB a couple months ago. I configured it to run TRIM and other optimisations and was incredibly happy with it.

Last week I step out for a few hours and leave the computer running. I was doing some heavy downloading through uTorrent (3 torrents at the same time) and had about 80GB free.

When I came back I found a BSOD with a c000021a error. When I rebooted, the BIOS couldn't "see" the SSD. So, I switched from AHCI to SATA and I could get to Windows startup but then the computer would hang at loading "ClassPnP.sys". Before anyone mentions this, I hadn't installed any new hardware or updates. The only weird issue I was having was that my DEll monitor USB slots seemed to be re-setting when I was running Windows. I thought it was some power issue.

Anyway, I tried different things to repair the installation. Unfortunately, startup repair would hang trying to load files. Inserting the Windows 7 cd didn't help either, as the computer would hang before even getting to the setup screen.

I installed a back-up hard drive on the system with Windows and tried to mount the SSD as external via an USB enclosure. When I turn it on a driver is found and the system recognises it as USB mass storage. It takes about five minutes to see it on Windows explorer, and when it does, it's just the icon, you can't access any other info. Running checkdisk on it hangs the system.

So, is the SSD fixable at all? Have you got any suggestions?