Crysis 2 freezes during gameplay


Aug 16, 2012
Hi, I am having issues while playing Crysis 2 on my PC. Occasionally after a long playing time say about 2 hours, the game suddenly freezes and does not respond to any of the keyboard or mouse events. I have to end the program from the task manager. It happens occasionally, but not frequently. I am not able to figure out the problem with it, I would appreciate if anyone can help me..

The following are my system specs:

Mobo: Intel DG31PR
CPU: Intel Dual Core E5300 @ 2.6 GHz (WolfDale)
Socket: LGA 775
PSU: Local Brand 450 W
RAM: Dynet 2 GB DDR2 800 MHz
GPU: AMD Radeon HD 7750 1 GB GDDR5
Driver: AMD Catalyst 13.3 Beta2

I am not having any issues with the PSU, GPU or the CPU in any of the other games that I play, but only in Crysis 2. I have been using the GPU for the past 5 months and not issues at all. I have not faced any issues in the following games:

1) Crysis & Crysis Warhead
2) Mafia 2 & All DLC's
3) NFS The Run
4) PES 2012
5) Battlefield 3
6) COD Black Ops (I get a slight stuttering during very intense gun fire, but I guess this is normal)


The resolution on which I game is 1280x1024
It's very difficult to say what the issue is. It may be a memory issue with you only having 2GB.

The only thing I can recommend is to change your settings:
1) ensure latest patch applied (1.9 I believe)
2) Disable DX11 if running
3) Disable HD textures if running
4) change quality settings to lowest default

I would ensure ALL FOUR of the above are done. If the game remains stable, increase the quality. I don't recommend the HD pack anyway for your PC.



Aug 16, 2012

I have already applied the latst patch and I am running the game under ultra settings with DX11 and HD Textures enabled. I do not experience the freezing frequently, but only after a long gameplay. I have tried lowering the settings, but still the same.. Any more ideas?

A couple points:
1) It will cost $60 plus tax/shipping for 4GB of DDR2:

*His motherboard has TWO slots and can support 667MHz or 800MHz of DDR2 up to 2GB per slot (4GB total).

2) If Windows is 32-bit then he will only gain about 700MB of System RAM. Windows 32-bit can address 4GB of addresses, not 4GB of System RAM. Out of that 4GB of addressable space the Video RAM is subtracted and some minor other things.

With Windows XP, a 1GB video card an 4GB of physical DDR2 installed he would likely have 2.7GB which is only a 0.7GB upgrade for close to $100 after tax/shipping of the 4GB of DDR2.

3) If Windows is 64-bit I strongly recommend a RAM upgrade. As well, a 0.7GB upgrade may not seem huge but if your issue is memory then it might be enough to solve your problem with Crysis 2.

4) When overclocking the CPU, make sure the RAM is not also overclocked. They usually share a common base clock so increasing the base clock for the CPU can also overclock the RAM an make it unstable. If you increase the base clock you may have to LOWER the RAM's multiplier so that the final frequency is no higher than recommended (i.e. 100MHz x 8).

5) Your 2GB does meet the minimum specs for the game.

1) I still advise you do all FOUR of my recommendations in my previous reply, especially ensuring the latest patch. (For your system, I definitely advise against using the HD textures and DX11 so just leave them disabled. So to repeat:
- DX11 and HD are OFF
- patched to v1.9
- set to LOWEST (or near lowest) settings to test.

2) If Crysis 2 takes two hours or so to crash, consider stopping and restarting the game after an hour or so.

3) *I'd be curious to know what FRAME RATES you can achieve (FRAPS to monitor with VSYNC OFF).

4) VSYNC OFF introduces screen tearing but responsiveness improved so it doesn't feel quite as sluggish. Depending on your setup this can too annoying though. If you want to improve game quality and keep VSYNC you can also use RadeonPro to force the HALF VSYNC method (will synch to 30FPS).

If possible though I would try to get to 50FPS or 60FPS with VSYNC (my monitor supports 50FPS but only at 1280x720 or 1920x1080; I suspect most monitors due for PAL compatibility). If Crysis 2 doesn't allow VSYNC at 50FP, RadeonPro probably can. I can no longer test this with my NVidia card though. Here's how to set things up:
a) run game with FRAPS and tweak settings until you rarely dip below 55FPS
b) Drag the main EXE file into RadeonPro
c) set a custom VSYNC (under Tweaks?) of 50FPS
d) turn off VSYNC in Crysis 2 (RadeonPro may overwrite anyway though I'm not certain).
e) Verify with FRAPS that 50FPS is working (you can press the proper F1 key to make the FPS disappear)

It's pretty handy especially for people like you who need to tweak more than most:
1) Forcing Anti-Aliasing:
Example: I did this with Mass Effect 1 and others. ME1 had no AA support and forcing it improved a lot. Usually I recommend MSAA but SuperSampling worked far, far better due to all the jagged lines. I managed 60FPS on an HD5870 at 4xAA SuperSampling.

2) Forcing VSYNC:
Example: Witcher #1. It had no VSYNC so screen tearing was horrible for me. You know it's working if RadeonPro or FRAPS show the FPS you set (i.e. 60FPS) though it won't work if your PC settings are too high and it can't produce that frame rate.

In a few games, I forced 30FPS instead of 60FPS while maintaining VSYNC. Generally for SLOWER games where the sluggishness isn't a big deal for which you want better quality but no screen tearing. This improved my SIMS 3 experience though I think I had issues finding the proper EXE file (again, you know it works when you see 30FPS displayed.. )



Similar threads