Crysis CPU Performance

Status
Not open for further replies.

ryokinshin

Distinguished
Mar 19, 2006
605
0
18,980
0
These threads are done till dead I realize, but I still need some help here.

AMD Phenom(tm) II X3 710 Processor (3 CPUs), ~2.6GHz
3326MB RAM OCZ Sli ram
1 TB WD Greenpower
ATI Radeon HD 4870
Windows Vista™ Business (6.0, Build 6001) Service Pack 1 (6001.vistasp1_gdr.090302-1506)
Asus M3A78-EM/CM

I seem to be getting very poor performance in this game from what I think is the CPU, 1280x800 with everything lowest I'm pulling below 30fps. All other games close to or beyond maximum and I have no idea what to do. Thinking it's the CPU based on testing around with the settings.
 

pat mcgroin

Distinguished
Nov 21, 2007
1,687
0
19,960
60
go to the control panel|power options and make sure high performance is marked.
Maybe its cool and quite having a issue.
Also be sure everything you can is turned off in the task manager.
See if that helps a little.


 

jimmysmitty

Polypheme
Moderator
I doubt your CPU is truly holding you back. I tested Crysis on my quad and it barely used much of all of it.

You could try OCing your CPU to say 3GHz and upping the res as the res you are playing at is a bit more CPU dependant so the GPU is not getting a workout.
 

mcnuggetofdeath

Distinguished
Oct 9, 2008
301
0
18,790
3
grab gpuz and make sure your gfx card is actually running at rated clocks. if not use rivatuner to set them. then disable cool & quiet in the BIOS. Its not your RAM ive got 2Gb and i average about 45-50 fps on all High settings (Dx9) at 1920x1080
 

B-Unit

Distinguished
Oct 13, 2006
1,837
1
19,810
5
It may be the RAM, did you buy a 3GB tripple channel kit? Phenoms only support dual-channel. Try taking one GB out and see if dual channel mode helps.
 

jedimasterben

Distinguished
Sep 22, 2007
1,172
0
19,360
43
Well, what drivers are you using?

What motherboard are you using, and did you install the drivers for it?

Have you had this problem in any other game?

Did you update Crysis to at least 1.2? This fixes a buttload of issues like this.
 

ryokinshin

Distinguished
Mar 19, 2006
605
0
18,980
0
Asus M3A78-EM/CM this is my mobo, I know about the bios being the latest, the drivers were from the disc. This is a problem in generally all the games I guess.
 

werxen

Distinguished
Sep 26, 2008
1,331
0
19,310
5
dude something is way off. i usually play crysis with max settings on mine at 1680x1050 with no AA or anything and i get ~ 30 fps. you need to reformat + update drivers from the website NOT the cd.
 

jedimasterben

Distinguished
Sep 22, 2007
1,172
0
19,360
43

ryokinshin

Distinguished
Mar 19, 2006
605
0
18,980
0
I don't even use the CD, I must address that I am competent with computers, although I can't seem to find out what is up with this particular problem.
 

werxen

Distinguished
Sep 26, 2008
1,331
0
19,310
5
hmm ok... well try this:

see what score you get in 3d mark.
also another noob thing, make sure your video card is ENABLED and not your mobo video card.
 
check you power options and make sure everything is set to high performance. Under the advanced option look for processor power management. make sure the minimum and maximum state are set to 100% You can also go into your bios and disable any kind of speed stepping (forgive me as I don't know what it's called for AMD CPUs).
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS