[SOLVED] Ctrl+Alt+Del doesn't work but Task Manager can be opened by other ways

Jan 26, 2019
3
0
10
0
Hello there;

Recently something weird happened to an old laptop of my cousin. It is a Dell Latitude E6400 running a Windows 7 Professional which when brought to me had lost some of its functionalities. One of them was that Ctrl+Alt+Del and Ctrl+Shift+Esc key combinations didn't work and everytime I pressed those keys nothing happened. So I thought it must certainly be a malware but just accidentally decided to see whether I can run Task Manager from the menu that appears by right-clicking on Taskbar and... yes, it STARTED and... it WORKED. Then I decided to check other basic Windows tools and components and see if I can run them. Surprisingly enough all of them worked as well: regedit, msconfig, cmd, gpedit.msc, services.msc, you name it. Everything just worked as it should. I was really confused why the malware didn't attempted to disable these programs.

Nevertheless I ran a full scan with an ESET Smart Security 8 that I had just updated its virus signature database and... again NO THREATS found.

I thought I'm going nowhere with this malware-hypothesis so thought of other things. Meanwhile I was also discovering that almost all key combinations of Ctrl, Alt, Shift and WinKey(a.k.a Windows Key) doesn't work as if they don't even exist on my keyboard which means for example if a file was being selected on the Desktop and I pressed Ctrl+Alt+Del the "Delete Confirmation Dialog Box" of that selected file would appeared (and not Windows Security Screen or Task Manager). Also Ctrl+C, Ctrl+V and Ctrl+A didn't work in any contexts. Ctrl+Esc didn't bring the Start Menu neither the WinKey. WinKey+R didn't bring Run and so on...
However some combinations of them worked. For example there was a difference between pressing Del(moving to recycle bin) or Shift+Del(permanent deletion) on a file.

I also guessed there may be something with the laptop's stock keyboard. I first uninstalled and reinstalled the keyboard driver from Device Manager and it didn't make any difference then I connected two other healthy and tested external keyboards and they were the same. So I was certain it couldn't be the keyboard.

It was getting weirder and weirder so I did everything I knew in my amateur brain. Here's a list of everything I tried to resolve the issue:

1. Made a new user account with administrative privileges and logged into it - The problem persisted.
2. Did a clean boot using msconfig's Diagnostic startup - It was still the same.
3. Manually disabled all startup services and executables from msconfig - Nothing changed.
4. Boot into Safe Mode - The problem was present even in Safe Mode.
5. Did a "sfc /scannow" - Nothing repaired.
6. Did a "chkdsk /f" - No errors reported
7. Used Startup Repair (ran it by pressing F8 during boot-up) - The Startup Repair said it possibly fixed something but it didn't (at least it wasn't my problem).

I also had a look in Registry Editor and Group Policy Editor and nothing seemed to be changed and modified. However I may just don't know which registry key or policy setting could be affected. I wanted to use System Restore too but there weren't any Restore Points being saved.

Now looks like I'm deadlocked here and only experts can help me. So I kindly request your helps.
Any answers will be appreciated.

P.S. I'm like 99% sure that re-installing the Windows will do the trick. But since this issue made me so curious I wanted to know if there's any other workarounds beside re-installing windows.

P.P.S. The idea of using some third party tools also came to my mind but since there are so many of them and some of them are unreliable from a security standpoint, I preferred to ask for their recommendation on the web and hopefully get reliable ones from the experienced people.
 

hang-the-9

Titan
Moderator
Maybe the CTRL key is not working? Unhook the keyboard, connect a USB one, see if that works. Did you try running a system restore to a time before this issue started?

Seems like that old joke "doctor, doctor, everywhere I touch hurts" "I see the issue, you have a cut on your finger".

Seems you listed a bunch of things that don't work, but all those things have something in common, they use the CTRL key. Then you said DEL key works, Shift + DEL works. Does ALT key work? Say if you have a folder open and you hit ALT+F to bring down the file menu? Does CTRL + C and CTRL + V work for copy and paste?
 
Reactions: hamedbegloo
Jan 26, 2019
3
0
10
0
Hi "hang-the-9"; Thank you for answering me.

As I predicted the Alt+F combination didn't bring down the File Menu in Windows Explorer. Also Alt+Tab didn't brought Task Switcher, Alt+Shift didn't changed keyboard's language(I have additional languages installed) & Alt+F4 didn't close any window. On the other hand as I mentioned WinKey didn't bring up the Start Menu, WinKey+R didn't made "Run" to show up and WinKey+E didn't opened Windows Explorer.
Ctrl+C and Control+V doesn't work for copying files and folders, neither do they work for copying texts.

Again I already mentioned that I used two external USB keyboards to see whether the problem persists and it did.(I confess that in my original opening post I wrote it in a way it implied that those keys worked in the external keyboards but by "flawlessly" I simply meant that they were as good as the built-in keyboard was. What a bad choice of words by me.)

As for the System Restore, someone (or some malware) probably configured it so that it never stores any Restore Points.

Nevertheless should I still unhook the built-in keyboard?

EDIT: I'm finding more deactivated keys. Just discovered that all Function Keys (F1-F12) don't work too; that is F1 doesn't open Windows Help, F2 doesn't rename a selected file or folder, F3 doesn't place the cursor in the Search Bar, F5 doesn't refresh the window(neither it refresh a web page) and so on.
And no, they don't work with the Fn key being hold down too.
 
Jan 26, 2019
3
0
10
0
Yeah. It seems you're right.
Just asked the same thing from my cousin and she said sometimes her 13 year old son plays games with it.
It seems to me that he sometimes plays with the laptop itself. (Those naughty little kids nowadays...)
Anyway just to update you back. I re-installed the Windows and the problem is gone.
Although I liked to go deeper about this but it seemed that it was just wasting my time.

Regardless, I thank you for all your helps.
 

ASK THE COMMUNITY

TRENDING THREADS