Cunning App-management Policies by Microsoft?

FrostBite-X Mritz

Commendable
Apr 11, 2016
4
0
1,510
0
Hello techies,

It's been a while I have noticed that many of the apps I have used (and have worked correctly) won't run anymore the next-time I try to run it. They have run before, but won't work now. It says 'This app can't run on your PC' even though they have worked before. After that thing shows, Windows won't allow you to execute the setup-file (it loads but nothing opens, it goes dead).
Now today, what happened was really frustrating, I tried to run a setup-file of a game. It was intact and was working well in other PCs, was supported upto Windows-8 and wasn't corrupted at all; but as soon as I tried to open it on my Windows-10 laptop; it's icon went null, file attributes got lost and bam 'This app can't run on your PC'. And it happened instantaneously, right in-front of me at that moment (screw you Microsoft, you're caught now). However, the size of the file remained intact, but it became unusable.
This thing happened with many apps, namely BlueStacks, Mozilla-Firefox and Opera (says 'runtime not found'), Windows-10 seems to delete important .DLLs too (as in the case of VLC Media Player, a core DLL-file went missing all of a sudden). I don't know what is going on with Microsoft and Windows-10 stuff, is there any solution for this?
By the way, I am quite sure that my system is not infected by any means. My system-configuration is as follows:

Asus R558U-Laptop -

Intel Core i5-6200U 2.30-2.80GHz Duo
2x4GB DDR3 RAMs @1600MHz
NVIDIA GeForce-930M 2GB DX12
64-bit Windows-10 Home v.1511

Thanks.
 

ASK THE COMMUNITY