Question Curious Issue After RAM Upgrade

May 15, 2020
3
0
10
0
I bought a pre-built about 3 years ago and decided I could do with some more RAM after all this time. The install went fine, but now I'm having strange issues where my framerate stutters in games and one of them (Civ 6) outright crashes after 2 minutes of being in-game and claims it's an issue with the graphics card. Drivers are current and didn't do that before the upgrade. No idea what the issue is.

Specs:
Cyberpower GUA2600BST
PSU: 500W
MB: MSI B350M BAZOOKA
GPU: Radeon RX 580 4GB
CPU: Ryzen 5 1400 3.2 GHz
RAM: 24 GB 2400 MHz DDR4 (was 8 GB)
 
May 15, 2020
3
0
10
0
Mixing RAM can cause issues. Try taking out the original 8gb. The RAM you bought was it a 2x8gb kit?
I've tried taking out the original, no difference. I bought 2 1x8 GB sticks as they sold out of any 2x8 GB kits. Should I try to put them on different channels and leave the original out?
 
I've tried taking out the original, no difference. I bought 2 1x8 GB sticks as they sold out of any 2x8 GB kits. Should I try to put them on different channels and leave the original out?
Your motherboard manual will say which 2 slots to use when you have 2 sticks. Usually it it #2 & #4 when counting from the left. Even mixing exact same and model bought separately can have issues.
 
May 15, 2020
3
0
10
0
Having just one in solved the issue. That is frustrating that you can't have the same make and model even on separate channels. sigh Guess I have to return them and hope I can find a good deal.

Thanks for the advice.
 

ASK THE COMMUNITY