Question Cursed case?? PSU?? help.

Sep 30, 2019
2
0
10
0
So I'll start by Listing current specs:
Phantek case
b450 tomahawk atx board
Ryzen 5 2600 cpu
EVGA super nova 650w psu
samsung nvme m.2 250gb
samsung qvo ssd 1TB
2 x 8GB Corsair vengeance rgb pro 3000mhz
Corsair h100i radiator cpu cooler
Samsung 49" curved ultra wide

so heres the problem,
I tried once before to upgrade the pc to a msi x570 mpg gaming edge wifi board with a new ryzen 5 3600 cpu, well got a no power problem, so i figured I'll check the wiring... no issues there, so i proceeded to buy a new full modular psu.. turned out the psu was doa.. replaced and also doa.. bought a different brand psu, got no power, did clip test, psu starts..

took everything out and put all old stuff back in, with old psu and poof, works...
bought my lady a case and put the new mobo and new psu and new cpu into her case and poof, works...

So i figured I would try again, bought a asus x570 tuf gaming plus wifi mobo, installed old cpu and old psu and I got fan spin (gpu fan was full spin) and dram debug light was on. . .

note touching 24pin mobo cable was temperamental ... finicky causing system off and on
- replaced 24 pin and got no power

swapped ram sticks with known good ram and same led came on and also tried different dimm slots and combinations of 1, 2 and 4 sticks

took new board out and replaced with old mobo (b450) with same cpu and same psu with original 24 pin and ...... poof.... working

Am I doomed to not upgrade mobo's? is it the case? cabling? picky psu? I have no idea at this point and could use some insight from a different perspective






 
Last edited by a moderator:

ASK THE COMMUNITY

TRENDING THREADS