Question Custom built PC booted/posted once, next day no luck. Persistent white LED now ?

Jan 18, 2022
1
0
10
0
Hello, I'm new here to the forums. I tried scouting similar/related content to find the answer to my problem and unfortunately, everything I tried led to no success.

Here are my system specs:
CPU: AMD Ryzen 7 5800X (I just bought this component yesterday and this was a new upgrade made)
MOBO: ASUS ROG STRIX B550-F Gaming
RAM: Corsair Vengeance Pro 32GB (4x8GB) 3200 Mhz (16GB of which was also purchased yesterday and added in)
GPU: Zotac Gaming 1660 Super
PSU: Corsair RM750 Fully Modular (also new)

Upon replacing my old CPU (the pins broke when attempting to update coolers a few weeks back, rookie mistakes were made),and installing the new PSU.. I was graced with a boot/post first try. Thank goodness.

Today however, not the same result. I installed a new cooler (just a CoolerMaster Hyper 212 RGB Black Edition, nothing spectacular) and two new sticks of RAM. I went to boot with confidence and.... no boot/post. Instead, I am given a slow orange > amber (red) > then white led pattern to which it stays steady on white. Per the MOBO manual, this indicates "no VGA" and per ASUS support instructions on their website it could indicate a faulty GPU.

Here's what I have tried:
  • I removed the cooler and 2x new sticks of RAM. No luck.
  • I checked all the connections to ensure everything was connected and seated properly.
  • I tried pulling the CMOS battery and reseating.
  • I tried clearing the CMOS by using a screwdriver to bridge the two pins (this was easily done, the motherboard has these pins set at the bottom under "CLR_TC".
  • I tried USB BIOS flashing to update the BIOS under the presumption that maybe it's the new 5th gen. CPU not being compatible with the current BIOS on the motherboard.
  • I swapped cables to the monitors, checked the connections for input and output. Both monitors are verified working as I'm actively using them both to type this thread connected to my laptop.
If I attempt to boot the system up without the GPU connected, it results in a solid white LED eventually leading to an additional green LED which indicates it failed to post.

When the system booted yesterday, it booted to the initial AMD branded screen where it told me "No keyboard detected", "CPU Fan Error", and something regarding RAID. It prompted me to press F1 and I neglected to doing so as I was on my way out the door, late for family lunch. Did I screw something up by not proceeding at that time?

On my to-do list to try:
- My buddy is going to let me pull his 3060 from his system to test and rule out the GPU as the culprit (hopefully). However, he's busy until Friday and it is currently Tuesday.. I do graphic design work on the side and have many clients waiting on me, I would like to rule out any other possibilities in the intermittent if possible.

Thank you for your time and assistance.
 

ASK THE COMMUNITY

TRENDING THREADS