[SOLVED] D-Link DIR 821 not working as access point (not assigning IP addresses)


Sep 10, 2014
Greetings all,

I'm having some issues with the router at the house I rent. The internet is included in the rent and the router in my house is set up as an access point from the router in the main building. The original router that was set up in here didn't work very well and eventually just kept dropping connections so I decided to replace it. So I bought a D-link DIR-821 and tried to set it up the exact same way as the other router (which is tricky because the ui is completely different) but it wouldn't work. So I looked up setting up the new router according to some online guides and did that and now my laptop can connect through the router but nothing else gets assigned an IP address.

The original router has to be plugged in to the WAP to work and has to have DHCP active. If I try that with the new router I can't make it work for the life of me. So I plugged the new router in to a lan port, turned of DHCP and have tried a ton of different IP addresses but always the same result. Anything other than my laptop trying to connect gets the "cannot obtain IP" message.

At the moment I don't have access to my computer but I could get you my IP config info if you need it.

I've been fighting with this for months and I'm losing my mind.

Thanks for your help!