Question D0 Error Code MSI mobo

baconieatdat

Distinguished
Aug 5, 2012
232
0
18,680
0
motherboard: msi z170a xpower gaming titanium

The background is going to be a little long because I’m truly stumped what went wrong.

I built my computer roughly 5 years ago and never had an issue with the computer. I recently took my computer apart to deep clean it. After putting it back together it worked just as it was before but I also did a fresh install of windows and fully updated windows. After this update, my computer still worked but everytime I would put it in sleep mode it would not wake up. The fans would start but the screen would never come back on. I would have to shut it down and restart it to get the display to work again. Before the fresh install of windows I also updated the BIOS which I hadn’t done since I got the board.

After about 2 weeks of this, I got a new fan controller and installed it. All I did was unplug the 4 fans from the motherboard and plugged them into the fan controller. I also did some wire managment in the back of my computer to clean it up a bit. All cords still had plently of slack to the motherboard and nothing happened out of the ordinary.

When I went to start my computer up I got the D0 error code on the debug display on my motherboard and it would not boot or post. After clearing the CMOS, removing the ram and gpu I was able to get the board to post. I reflashed the BIOS and reinstalled the ram and gpu and the computer booted like normal. The board was recognizing all hardrives, ram, cpu and gpu.

I then tried to install valorant. Since vanguard needs you to restart your computer I hit restart and a memory error message popped up for a quick second before the computer restart. On the restart I got the D0 error again and again it would not boot or post. I tried the steps I tried previously to get it to work again and it did not work this time I’m still getting the error everytime.

I now have the board removed from my case and completely stripped down to just the mobo power cables (ram, gpu, nvme ssd and cpu all removed). When trying to power on the board I still get the D0 error code. I have also tried to flashback the bios and the flashback seems to work but upon booting I get the D0 error.


Sorry for the long background but I have no idea what could have caused the board to brick like this. I had no issue for 5 years and did not do anything that could have possibly damaged the board. Any help or troubleshooting ideas would be greatly appreciated.
 

ASK THE COMMUNITY