Question Dark rock 4 no post but fans light up and spin as well as case fans.

Jan 10, 2021
4
0
10
0
Bought a dark rock 4 installed it and..... no post took it out cleaned the cpu and bottom of the heatsync and tried again yet again the same thing case fans and heatsync fan spinning but no post. So installed the stock cooler again and it booted up and it said new cpu and prompted me to go through the bios settings but I just pressed enter or whatever to save them as they where any suggestions as why it didn’t post?

specs:
Ryzen 5 3600
ASUS b450m-A
EVGA GeForce rtx 2060 super
16GB Corsair vengeance 3200mhz RAM
1TB m.2 intel
Corsair CV550 psu
 
Jan 10, 2021
4
0
10
0
I tightened it to the point where it wouldn’t move side to side and when I re-installed the stock cooler I did the same are you sure that it’s that I want to be sure before I return it
 

Phaaze88

Champion
Ambassador
You tightened it to where the heatsink wouldn't move side-to-side, instead of stopping when the screws 'stopped'? That's backwards.
No other reason I know of - from my experience - than over-tightening.
 
Jan 10, 2021
4
0
10
0
Yeah I obviously stopped tightening the screws when they wouldn’t go any further and I didn’t purposely try to go beyond that either just confused at the stock cooler worked fine straight after also this pc was pre built
 

Phaaze88

Champion
Ambassador
Stock cooler is EZ Mode; simple to install, hard to screw up.

I remember the Dark Rock 4's fan being a pain to install, but I might not have followed the instructions correctly - but I only installed it once on a 8086K that I gave to my brother.
 
Jan 10, 2021
4
0
10
0
it’s a pain to install the fan yeah and you think I installed it too tight ? Was going to have it fitted since I’m having no luck
 

ASK THE COMMUNITY

TRENDING THREADS