[SOLVED] Date/time reset in BIOS every boot - AsRock X570 Phantom Gaming

Feb 20, 2022
3
0
10
0
Hello,
I have an issue with date/time clock after the BIOS update of my PC's motherboard. An X570 Phantom Gaming-ITX/TB3

I updated from bios version 3.0 to 3.20 my PC's motherboard. After the update my system start until to the bios boot but the OS (Windows 11) can't be start.

I tried to downgrade to previously BIOS version (3.0) and after the downgrade the OS Windows started regulary again, but the date/time clock of the bios can't be mantain the correct set and at every switch on of the PC or reboot, BIOS clock is reset to 2017.
I tried to update the BIOS again to version 3.1 but the date/time issue still.
BIOS battery is Ok.

Someone had the same problem and found a solution?
 
Feb 20, 2022
3
0
10
0
usually this is caused by a failing CMOS battery.

if you have no new spare to replace it with just take it to a local hardware or Walmart type store and have them find you a replacement.
Hi JohnBonhamsGhost,

thanks but it's not the battery.
Battery is new and the voltage value is correct.
Date/time in Bios are reset also after a simple hot-restart of the PC.
 
Feb 20, 2022
3
0
10
0
if you have recently replaced the CMOS battery with a new one and the BIOS still cannot maintain updated data then you just have a malfunctioning board.

if you are just stating that the CMOS battery is new because it is a new board, then you are probably mistaken because you have no idea how long this product may have sat.
You are right. I'm in the second one case, but I tested the voltage of the battery under load and it have 2.99 volts. Without load the voltage of the battery is 3.0V.
I'll can try to change it, but I don't think that is the problem.
Thanks for your suggestion.
 

ASK THE COMMUNITY

TRENDING THREADS