Question DDR3 memory, 16.0GB installed, 6.94 usable?

beppomarx

Distinguished
Apr 6, 2011
32
0
18,530
0
Hello! I am an avid tomshardwae reader but rarely post, however I am kind of stuck... I have 2x4GB GSkill memory modules which I assume have been working fine for years. I just came across a set of 2x4GB Crucial Ballistix and installed it. Well, Windows now states 16.0GB but 6.94 usable, CPU-Z recognizes 16 and Passmak detects 4098??? I normally don't play with memory timings but after seeing this and since these are not the same brand and all I set all 4 modules to 9-9-9-24 and no change, now I have loosened it up as you can see to 10-10-10-27 which I feel these parts should have no problem with. I have options in the BIOS to address dual rank and dual channel (I cant remember the exact wording without going back in) have tried them both at auto and enabled as well. Maybe one of the modules is bad? I'm stumped- maybe there is a test that can tell me if there is a faulty stick so all recommendations are welcome. Here is a link to a screenshot of what I am seeing:

RAM picture

Any advice is welcome, thanks in advance!!!
 

COLGeek

Cybernaut
Moderator
I would suggest changing your memory settings to AUTO in the BIOS and let the motherboard determine the most compatible settings. Unfortunately, this is a common occurrence when mixing memory makes/models.

You should also consider resetting your BIOS to its default state to see if that helps.

Also, make sure your motherboard is running the most recent BIOS version available for it.
 
Memory is guaranteed in the form sold. No memory manufacturer would guarantee the combination you have to be compatible together.

Workarounds to get extra memory to work include:
Lower memory clock speed
Relax DRAM timings
Increase DRAM voltage
 

ASK THE COMMUNITY

TRENDING THREADS