• Hey there, Guest! Share your idea for a new trophy in the forums and win bragging rights and a $100 Amazon gift card! Check out the New Community Trophy Contest here!
  • Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

Dead ethernet plug after upgrading GPU


Nov 20, 2008
my onboard ethernet suddenly does not work anymore after changing to a radeon 5750 gogreen graphic card.
windows 7 does not recognise it in device manager under "network adapters" anymore. The list is simply empty! and when I choose to show the hidden stuff its just stuff thats not related to the onboard lan..

Ive tried going into safe-mode, unplugging the new gpu and put the old back in to no avail...
Ive made sure that "realtek lan" is enabled in bios.
The plug does not blink green anymore when I put the cable in,..
any ideas what went wrong and how to fix?

Im now using a wireless-usb dongle and it works normally..
But I still need the onboard ethernet to work

i7 920, asus p6t se motherboard w latest bios, 6 gig ram ocz, radeon 5750 gogreen pcie, windows 7 sp1 64 bit, LAN: Realtek 8111C PCIe Gigabit LAN controller onboard.


Aug 20, 2010
Sometimes ethernet controllers hang and by removing power from PSU or turning it off for a few seconds or a minute or so may fix the problem.

Lights should turn on even if PC is shutdown (PSU on). That's for wake on lan feature to work.

If not, maybe its burnt out, you could either RMA mobo or if can't be bothered buy a cheap controller of ebay and do you job (10$ or so).
Your statement "windows 7 does not recognise it in device manager under "network adapters" anymore." may indicate a hardware resource conflict.

Have you tried clearing the CMOS RTC RAM?

The following instructions are from ASUS' P6T SE Motherboard manual:

Clear RTC RAM (3-pin CLRTC) Jumper

This jumper allows you to clear the Real Time Clock (RTC) RAM in CMOS. You can clear the CMOS memory of date, time, and system setup parameters by erasing the CMOS RTC RAM data. The onboard button cell battery powers the RAM data in CMOS, which include system setup information such as system passwords.

To erase the RTC RAM

1. Turn OFF the computer and unplug the power cord.

2. Move the jumper cap from pins 1-2 (default) to pins 2-3. Keep the cap on pins 2-3 for about 5-10 seconds, then move the cap back to pins 1-2.

3. Plug the power cord and turn ON the computer.

4. Hold down the <Delete> key during the boot process and enter BIOS setup to re-enter data.

! Except for when clearing the RTC RAM, never remove the cap from the CLRTC jumper's default position. Removing the cap will cause system boot failure!
■If the steps above do not help, remove the onboard battery and move the jumper again to clear the CMOS RTC RAM data. After the CMOS clearance, reinstall the battery.
■You do not need to clear the RTC when the system hangs due to overclocking. For system failure due to overclocking, use the C.P.R. (CPU Parameter Recall) feature. Shut down and reboot the system so the BIOS can automatically reset parameter settings to default values.
■Due to chipset behavior, AC power off is required to enable C.P.R. function. You must turn off and on the power supply or unplug the power cord before rebooting the system.


Dec 24, 2014
This is an old question but deserves an answer after I had the same issue recently. Is your Ethernet card dead? yes it is and your motherboard will follow. Why did this happen when you changed GPU? Asus seems to share the power of PCIE lanes with other devices. When you enter a GPU that requires power from the PCIE lane and the PSU separately then this might cause these issues.
I had an ASUS 7970 which was taking 2x 4-pin plugs from the PSU. Recently replaced it with a 290X that takes a bit less power from the PSU and some fro the lane. This caused the etherent and usb headers to die.
Long story short, get a new motherboard

Similar threads