Question "Dead" PC.

Jun 5, 2020
2
0
10
0
I have a very old PC, an Advent T9508 - I tried to install two new matched RAM sticks into it. I wanted to upgrade the OS too. Very infrequently used, but has been working fine for many many years.

I had to remove my GPU to get out the RAM as locking clip was hitting GPU, couldn't get RAM out. Put new RAM in, no POST "success" beep. No image on monitor. Swapped back to old RAM - worked fine. Decided to try again: put new RAM in, unseated CMOS battery to see if that would help. Same, no POST no monitor image. Put old RAM back, made POST ok, but bios.ini was corrupt - no prob, I could fix that. Computer ran ok on its side. I then turned off and put vertical as it should be. Turned on: distressed mobo beeping. In a panic I turned off at the rocker switch.

Put back on side, hit power but, mobo fan sputtered and started, then stopped (inbuilt LED on power switch did same, turned off/on in time with fan).

My power-on wiring arrangement seems a bit odd. From the momentary switch there were three terminals, a blue wire, a central white wire, an orange wire. White and orange go to mobo two pin terminal POWER S. Blue goes to a two pin molex. A white wire goes from the power button light-up LED to that two pin molex. From that molex, it goes to a female molex, along the chain to PSU.

the blue wire had unfortunately been stressed and has come out of the momentary switch cube. In trying to multimeter the orange wire on momentary switch, i pulled it off too. (can you see a pattern?)

I tested every molex in my PSU, by forcing it on with the paperclip test. Everything gives correct voltages. The blue wire has +ve 5.something volts when I have it as live and ground the multimeter on a white wire.

I did accidentally put the POWER S on the wrong pins when trying to test, so i put it on in it's correct orientation but on the HDD LED terminal, and I put it on the incorrect orientation: on a spike of the POWER S and a spike of the HDD LED :(

I have connected and reseated each connector on mobo, but mobo fan does not spin, nor does PSU fan or rear fan.

I believe it is a problem with the momentary switch, but even touching the loose blue wire to it's former connection site (i poked it into the switch cube, and touch it onto a bare terminal) and pressing the momentary switch on does not work. I have also put the blue wire on the bare power LED terminal - which does not illuminate.

I note that if I touch the orange wire to the light-up LED in my front fascia it illuminates (if PSU is on using rocker switch). To me that sounds like power is somehow making it's way through from power, to mobo to the two pin connectors, to my loose orange wire?

I do not have a "reset switch" to make that a new power switch.

Can anyone help? I'd be very grateful to hear any ideas/test plans.

I added some photos here: View: https://imgur.com/a/mp4ui8F
(ignore last one, it was for a friend to look) and some here. View: https://imgur.com/a/Oa4SKCj


I can take more.


Thank you.
 
Jun 5, 2020
2
0
10
0
PS, if I paperclip the ATX, and insert the "+4" molex which sits beside the 20 molex, the mobo and rear fans spin at normal speed it sounds like.

I then added an HD, and it spun up and "clicked" sounding like it was "on".

If I then touch blue wire to power led it lights the switch at normal illumination, but I don't think blue wire was ever on there. I don't know how an led with only one connected leg could have illuminated.

Could I put paperclip in top of molex so it pokes out, and re-insert the 20 connector? Then reconnect HDs? Using rear rocker as on/off?

I note the red HDD led is constantly illuminated when ATX is paperclipped, I don't recall it always being on.

Blue wire shows 5v. Orange about 3.3. blue wire plus bare led leg 2.80. blue wire and middle of momentary (with white wire connected) =5v.

Orange wire didn't seem to give an Vs, as not connected to anything except it's Power Sw connector into mobo.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS