Question Dead SATA port, any fixes?

Jan 14, 2021
2
0
10
0
So, I got a new CPU cooler, which required me to disassemble my entire system (considering it was hard to install it while everything was in the case) and once I assembled everything back I saw one of my hard drives not being detected and my PC wouldn't even turn on (past the MOBO loading screen, sometimes I could get into BIOS, other times it would just freeze). Upon further inspection (aka. a bit of googleing and what not) it was the hard drives fault that I couldn't get it. At first I thought it was the drive but it turns out it's the port (after many restarts, and changing the SATA cables (the disk works fine)).
Other ports (3) are working perfectly fine. Is there any hope for this or I'll just have to move one with only one HDD, which is not that big of a deal but still... (I don't really want to send my mobo for warranty as I don't have a replacement and I need my PC for work, school and what not)?
Also I have the B550 Aorus Elite.

Edit: The port is detected in BIOS (but it says N/A even if the disk was connected to it).

Edit #2:
PC Specs
Motherboard: B550 Aorus Elite
CPU: Ryzen 5 3600 (Wraith Prism RGB cooler)
RAM: Corsair Vengeance 4x8 GB DDR4 3200 MHz
GPU: RX 590 8 GB
PSU: Corsair RM 650x
Storage: Samsung 860 EVO 250 GB, Samsung 860 EVO 500 GB, Toshiba 1TB HDD & WD 1TB HDD
 
Last edited:

Ralston18

Titan
Moderator
Update your post to include full system hardware specs and OS information.

Open Powershell and run "Get-PhysicalDisk" via the PS prompt.

As an example:

PS C:\WINDOWS\system32> Get-PhysicalDisk

Number FriendlyName SerialNumber MediaType CanPool OperationalStatus HealthStatus Usage
------ ------------ ------------ --------- ------- ----------------- ------------ -----
2 ST1000DM 010-2EP102 1 Unspecified False OK Healthy Auto-...
1 KBG30ZMS256G NVMe TOSHIBA 256GB 0008_0D04_0023_14F4. SSD False OK Healthy Auto-...
0 Samsung SSD 860 EVO 500GB S59UNS0N502804E SSD False OK Healthy Auto-...
 
Jan 14, 2021
2
0
10
0
Here's what I get (the other disk isn't connected as I said, I can't even enter Windows with something connected to that port)

Number FriendlyName SerialNumber MediaType CanPool OperationalStatus HealthStatus Usage Size
------ ------------ ------------ --------- ------- ----------------- ------------ ----- ----
0 Samsung SSD 860 EVO 250GB S4CJNF0MB09533E SSD False OK Healthy Auto-Select 232.89 GB
2 WDC WD10EZEX-00BN5A0 WD-WMC3F0645986 HDD False OK Healthy Auto-Select 931.51 GB
1 Samsung SSD 860 EVO 500GB S4XBNF0MB14393J SSD False OK Healthy Auto-Select 465.76 GB
 

ASK THE COMMUNITY