Decent Build has problem running certain games!?

Oct 3, 2018
1
0
10
0
So about a year ago, my friend had someone custom-build his PC for him, on a budget. The PC has an Intel Pentium G4560, Hyper 212 Evo CPU fan, Gigabyte - GA-H110M-A Micro ATX LGA1151 Motherboard, MSI GTX 1050 Ti 4GB Gaming X 4G video card, a bronze certified power supply by Corsair, and a TB hard drive by Western Digital.

When he first started to use the computer, the PC would run games like Fortnite and CS:GO fine, but Tom Clancy's Rainbow Six Siege would run horribly: 1-30 fps on the lowest settings. His frames would fluctuate abnormally and it would affect his gameplay a lot, obviously. Then, after a couple more months in, his Rainbow Six game ran completely fine, on max settings, at around 200 frames per second. However, at the same time Rainbow Six started to run normally, Fortnite's performance dramatically decreased. On lowest settings, the game would now run at 40 frames or lower. Fast forward a little bit and now, Fortnite has gotten better, with 120 frames on medium settings, but it would still randomly spike down to 20 frames quite frequently for a few seconds, then go back up. I'm sorry for making you read all of this, but I would love some suggestions as to why this might be happening and some help! His PC has been like this ever since he first got it.

I have kept my drivers and bios up-to-date. Have also tried modifying Nvidia Control Panel, as others have suggested.
 

Similar threads


ASK THE COMMUNITY