default action on folder click

G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

XP Home Ver. 2002 SP2

OPEN is no longer the default action when clicking on a folder. I have to
right click the folder and choose OPEN from the list. How can I make OPEN the
default action again?

Background: I added an action for the File Folder file type that prints out
a listing of the folder. The action at the top of the list of File Folder
actions became the new default. I did not select Set Default. There is no
Open action in that list. I would like to keep the new Print Listing action
but want Open to be the default again.
 

Jo

Distinguished
Apr 14, 2004
262
0
18,780
0
Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Tom, See this link
http://support.microsoft.com/default.aspx?scid=kb;en-us;321379
See the "Edit the registry" section. This will solve your problem.

"Tom Ahasic" wrote:

> XP Home Ver. 2002 SP2
>
> OPEN is no longer the default action when clicking on a folder. I have to
> right click the folder and choose OPEN from the list. How can I make OPEN the
> default action again?
>
> Background: I added an action for the File Folder file type that prints out
> a listing of the folder. The action at the top of the list of File Folder
> actions became the new default. I did not select Set Default. There is no
> Open action in that list. I would like to keep the new Print Listing action
> but want Open to be the default again.
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Tom,

This problem occurs when you alter the "Drive" / "File Folders" entries via
File Types dialog, to add a "Command Prompt here" or "Print Directory"
feature for folders. (example)

http://support.microsoft.com/?kbid=321379
http://support.microsoft.com/?kbid=321186

Resolution:

Click Start/Run and type this command to fix this problem:
(Tip from David Candy)

regsvr32 /i shell32.dll

-or-

To fix this manually via registry:

If this problem is seen for Drives:

HKEY_CLASSES_ROOT\Drive\shell
Set (default) to "none" (without ")

If this problem is seen for folders:

[HKEY_CLASSES_ROOT\Directory\shell]
Set (default) to "none" (without ")


--
Ramesh, Microsoft MVP
Windows XP Shell/User
http://windowsxp.mvps.org


"Tom Ahasic" <Tom Ahasic@discussions.microsoft.com> wrote in message
news:84556ECF-C484-449F-BF02-7AF3AE8DE369@microsoft.com...
> XP Home Ver. 2002 SP2
>
> OPEN is no longer the default action when clicking on a folder. I have to
> right click the folder and choose OPEN from the list. How can I make OPEN
> the
> default action again?
>
> Background: I added an action for the File Folder file type that prints
> out
> a listing of the folder. The action at the top of the list of File Folder
> actions became the new default. I did not select Set Default. There is no
> Open action in that list. I would like to keep the new Print Listing
> action
> but want Open to be the default again.
 

Similar threads